summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlexey Neyman <stilor@att.net>2018-02-02 06:16:05 (GMT)
committerGitHub <noreply@github.com>2018-02-02 06:16:05 (GMT)
commitfd9fe523b22cb6281f26081232a3f8f3aee7fda1 (patch)
tree9851733e0973e1de900d7f932e5b88fe637441f3 /configure.ac
parentba165ed4c0bfa8a83e61a2efd1ad205777978486 (diff)
parent36bb675a71cc66a2abd69bc82d613f2153d3791f (diff)
Merge pull request #904 from stilor/upgrade
A bunch of upgrades
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 17 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 24dcbcd..8ae98bf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -119,6 +119,22 @@ AC_DEFUN(
[AC_MSG_ERROR([Required tool not found: $2])])
])
+# Check if install(1) supports --strip-program=...
+AC_DEFUN(
+ [ACX_INSTALL_STRIP_PROGRAM],
+ [touch conftest
+ mkdir conftest.dir
+ AC_MSG_CHECKING([if install takes --strip-program option])
+ AS_IF([$INSTALL --strip-program=true -s conftest conftest.dir/conftest 2>/dev/null],
+ [install_with_strip_program=y
+ AC_MSG_RESULT([yes])],
+ [AC_MSG_RESULT([no])])
+ ACX_SET_KCONFIG_OPTION([install_with_strip_program])
+ rm -rf conftest.dir
+ rm -f conftest
+ ])
+
+
#--------------------------------------------------------------------
# Allow dummy --{en,dis}able-{static,shared}
AC_ARG_ENABLE(
@@ -159,6 +175,7 @@ AC_ARG_PROGRAM
ACX_WITH_DEPRECATED([install], [INSTALL])
AC_ARG_VAR([INSTALL], [Specify the full path to a BSD-compatible install])
AC_PROG_INSTALL
+ACX_INSTALL_STRIP_PROGRAM
ACX_WITH_DEPRECATED([grep], [GREP])
AC_ARG_VAR([GREP], [Specify the full path to GNU grep])