summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlexey Neyman <stilor@att.net>2017-04-24 03:08:26 (GMT)
committerGitHub <noreply@github.com>2017-04-24 03:08:26 (GMT)
commit88fdbac4252744931ebcf80ade547ade525b71f4 (patch)
tree6c77f523d5c34bbf7ae1df1839f2f4275e505850 /configure.ac
parent368a0169a27313cca60cf7d7358b6f3ef12122e4 (diff)
parentf98e04388c805a1b97b7a49e0d2da5c9acbcf887 (diff)
Merge pull request #697 from stilor/makefile-enhancements-orig
Makefile enhancements
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 4 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index d10bf71..869226c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -65,10 +65,9 @@ AC_DEFUN(
AC_DEFUN(
[ACX_SET_KCONFIG_OPTION],
[AS_IF(
- [test -n "$$1"],
- [kconfig_options="$kconfig_options has_$1=y"],
- [kconfig_options="$kconfig_options has_$1"])
- ])
+ [test -n "$$1"],
+ [AC_SUBST([KCONFIG_$1], ["def_bool y"])],
+ [AC_SUBST([KCONFIG_$1], ["bool"])])])
# Check if a given program is available with a particular version.
# ACX_PROG_VERSION(VAR, HELP, PROG, SRCH, VERSION_CHECK[, CONFIG_OPT])
@@ -466,5 +465,5 @@ AS_IF(
#--------------------------------------------------------------------
# Finally, generate the output file(s)
#--------------------------------------------------------------------
-AC_CONFIG_FILES([Makefile])
+AC_CONFIG_FILES([Makefile config/configure.in])
AC_OUTPUT