summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorYann E. MORIN" <yann.morin.1998@anciens.enib.fr>2012-01-14 17:22:06 (GMT)
committerYann E. MORIN" <yann.morin.1998@anciens.enib.fr>2012-01-14 17:22:06 (GMT)
commitcb7fcbe1ef4ffba4c3041c4d4414d5b41856691c (patch)
treee39c790b713682f98e3fcb67a139bd4a4464695b /configure.ac
parentc8e39d6d298f921b8b510bb88bc210fb30f0bd10 (diff)
kconfig: install compiled frontends
The kconfig frontends are currently instaleld as source files. This is a remnant of the early times, when I wanted a single installation of crosstool-NG to be shared across multiple machines, potentially of different architectures. This does not really make sense, and it's been a long time since it was las tpossible in practice. So, just build the kconfig frontends at make-time, and install them as we do for all other crosstool-NG dependent files. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@anciens.enib.fr>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 18 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index ab9640a..0be5b90 100644
--- a/configure.ac
+++ b/configure.ac
@@ -251,11 +251,27 @@ AC_HEADER_STDC
AC_FUNC_MALLOC
AC_FUNC_REALLOC
AC_FUNC_ALLOCA
+
+#----------------------------------------
+# Check for gettext, for the kconfig frontends
+AC_SUBST([gettext])
+AC_CHECK_HEADERS(
+ [libintl.h],
+ [ac_ct_gettext_hdr=$ac_header; break])
+AS_IF(
+ [test -n "$ac_ct_gettext_hdr"],
+ [AC_CHECK_DECL(
+ [gettext],gettext=y,,
+ [#include <$ac_ct_gettext_hdr>])])
+
+#----------------------------------------
+# Check for ncurses, for the kconfig frontends
+AC_SUBST([ac_ct_curses_hdr])
AC_CHECK_HEADERS(
[ncurses/ncurses.h ncurses/curses.h ncursesw/curses.h ncurses.h curses.h],
- [ac_ct_curses_hdr_found=yes; break])
+ [ac_ct_curses_hdr=$ac_header; break])
AS_IF(
- [test -z "$ac_ct_curses_hdr_found"],
+ [test -z "$ac_ct_curses_hdr"],
[AC_MSG_ERROR([could not find curses header, required for the kconfig frontends])])
AC_SEARCH_LIBS(
[initscr],