summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRay Donnelly <mingw.android@gmail.com>2013-09-14 01:45:23 (GMT)
committerRay Donnelly <mingw.android@gmail.com>2013-09-14 01:45:23 (GMT)
commitd2bc2be8db11a678c5caff8a6a5b6bcadd3fc3b7 (patch)
treef2441559157b0836837a166324247895974dcdbb /configure.ac
parentc0c6db07fe47150709dd863a8aab9d324b8cb6df (diff)
configure: Add --with-gperf option
On OS X, Apple supply an old gperf (3.0.3) with xcode and xcode commandline tools which causes build failures: ./zconf.hash.c:183:17: error: expected expression {offsetof(struct kconf_id_strings_t, kconf_id_strings_str2), .. upgrading to gperf 3.0.4 was sufficient to fix this, so this option allows the user to specify the gperf program that they wish to use. To install gperf 3.0.4 from homebrew, I did: brew tap homebrew/dupes brew install homebrew/dupes/gperf .. then passed --with-gperf=$BREWFIX/Cellar/gperf/3.0.4/bin/gperf to configure Signed-off-by: Ray Donnelly <mingw.android@gmail.com> Message-Id: <CAOYw7dtCmcJ9WiqmQ81MmZeRPcV-tDOqe9=kRDW4uQGuZNd2Ng@mail.gmail.com> Patchwork-Id: 274892
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 719d3cb..df3f9dd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -143,15 +143,19 @@ AC_ARG_WITH([readelf],
AS_HELP_STRING([--with-readelf=PATH],
[Specify the full PATH to GNU readelf]),
[READELF=$withval])
+AC_ARG_WITH([gperf],
+ AS_HELP_STRING([--with-gperf=PATH],
+ [Specify the full PATH to GNU gperf]),
+ [GPERF=$withval])
AC_PROG_RANLIB
ACX_PATH_TOOL_REQ([OBJCOPY], [objcopy])
ACX_PATH_TOOL_REQ([OBJDUMP], [objdump])
ACX_PATH_TOOL_REQ([READELF], [readelf])
+ACX_PATH_TOOL_REQ([GPERF], [gperf])
ACX_CHECK_PROGS_REQ([bison], [bison])
ACX_CHECK_PROGS_REQ([flex], [flex])
-ACX_CHECK_PROGS_REQ([gperf], [gperf])
ACX_CHECK_PROGS_REQ([makeinfo], [makeinfo])
ACX_CHECK_PROGS_REQ([cut], [cut])
ACX_CHECK_PROGS_REQ([stat], [stat])