summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBryan Hundven <bryanhundven@gmail.com>2015-09-29 23:22:49 (GMT)
committerBryan Hundven <bryanhundven@gmail.com>2015-09-29 23:22:49 (GMT)
commit4f266e1a8c78cec2c425b17784576db56125bbbd (patch)
treee28732437ddc94ed35056c145807a46addafd34f /configure.ac
parent6baef82c26f0586ce53373760ac550b0d2536626 (diff)
configure: Add automated build option
This commit introduces a configure time option to let the build know that this is going to be an automated build. This forces the build to disable the progress bar, log tool warnings, and force the log level to debug. Signed-off-by: Bryan Hundven <bryanhundven@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index adde2ab..5670a03 100644
--- a/configure.ac
+++ b/configure.ac
@@ -67,6 +67,16 @@ AC_ARG_ENABLE(
[do not install, and use current directory])])
AC_SUBST([enable_local], [${enable_local:-no}])
AC_ARG_ENABLE(
+ [automated],
+ [AS_HELP_STRING(
+ [--enable-automated],
+ [Tell ct-ng that this is an automated build])],
+ [if test "x$automated" = "x" -o "x$automated" = "xyes"; then
+ automated=y
+ fi])
+AC_SUBST([enable_automated], [${enable_automated:-no}])
+ACX_SET_KCONFIG_OPTION([automated])
+AC_ARG_ENABLE(
[shared],
[AS_HELP_STRING(
[--enable-shared],