summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBryan Hundven <bryanhundven@gmail.com>2015-11-13 05:50:31 (GMT)
committerBryan Hundven <bryanhundven@gmail.com>2015-11-13 05:50:31 (GMT)
commit57de8dcf22d5ddddee6a44f87f45f2c279fdb1ac (patch)
tree9477fd0a23bbe297fd11178b7ed6cd8c3c8a268a /configure.ac
parent4c9218d51dc3c6c84a8d5c488f234ed7575107c6 (diff)
parent5f3774cd656ba54200cb192fc1454c5232347b70 (diff)
Merge pull request #239 from diorcety-ctng/cc-cygwin-mingw-linux
Canadian cross build = x86_64 Cygwin host = x86_64 MinGW_W64 target = x86_64 GNU/Linux
Diffstat (limited to 'configure.ac')
-rwxr-xr-x[-rw-r--r--]configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index adde2ab..b922482 100644..100755
--- a/configure.ac
+++ b/configure.ac
@@ -171,6 +171,7 @@ ACX_CHECK_PROGS_REQ([wget], [wget])
ACX_CHECK_PROGS_REQ([tar], [tar])
ACX_CHECK_PROGS_REQ([gzip], [gzip])
ACX_CHECK_PROGS_REQ([bzip2], [bzip2])
+ACX_CHECK_PROGS_REQ([help2man], [help2man])
#--------------------------------------------------------------------
# Still boring, but remember the path, now...
@@ -320,7 +321,7 @@ AC_FUNC_REALLOC
AC_FUNC_ALLOCA
#----------------------------------------
-# Check for gettext, for the kconfig frontends
+# Check for gettext and libintl for the kconfig frontends
AC_SUBST([gettext])
AC_CHECK_HEADERS(
[libintl.h],
@@ -332,6 +333,10 @@ AS_IF(
[gettext=y],,
[AC_INCLUDES_DEFAULT()
#include <$ac_ct_gettext_hdr>])])
+SAVE_LIBS=$LIBS
+AC_SEARCH_LIBS(bindtextdomain, intl, [test "$ac_res" = "none required" || INTL_LIBS="${ac_res}"])
+LIBS=$SAVE_LIBS
+AC_SUBST([INTL_LIBS])
#----------------------------------------
# Check for ncurses, for the kconfig frontends