summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBryan Hundven <bryanhundven@gmail.com>2015-06-03 18:08:57 (GMT)
committerBryan Hundven <bryanhundven@gmail.com>2015-06-03 19:32:34 (GMT)
commit0e45cdf62422fbcc69c10d4287c7f8a2f96c149d (patch)
treeec12810ccb8f212cb6737ed13dad858fb987c188 /configure.ac
parent542f126b5bbf1e8e79af79ea80f31e548ec6c283 (diff)
autoconf: Update version numbering
This change removes the static .version file, and moves to using the git tag as the version number, the change number if the current commit is newer then the latest tag, and '-dirty' if there are changes to the git repository since the last commit that are uncommitted. This helps us in the troubleshooting process to identify if the user is: * using a released version (i.e.: 1.21.0) * using a clone from git (i.e.: 1.21.0-29-13e14f) * using a clone from git with local uncommitted changes (i.e.: 1.21.0-29-13e14f-dirty) Signed-off-by: Bryan Hundven <bryanhundven@gmail.com> Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 9899a3b..573d0b9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2,7 +2,10 @@
# Process this file with autoconf to produce a configure script.
AC_PREREQ([2.67])
-AC_INIT([crosstool-NG], [m4_esyscmd_s([cat .version])], [crossgcc@sourceware.org])
+AC_INIT(
+ [crosstool-NG],
+ [m4_esyscmd_s([git describe --always --dirty])],
+ [crossgcc@sourceware.org])
AC_CONFIG_AUX_DIR([scripts])
#--------------------------------------------------------------------