summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlexey Neyman <stilor@att.net>2017-06-07 03:06:04 (GMT)
committerAlexey Neyman <stilor@att.net>2017-06-08 05:38:53 (GMT)
commit1b4e784a0ba636646def1db5ca012fd54ee7a81c (patch)
tree175814b416570817c9a16f3174276ea4cce78bbf /configure.ac
parent10089f3c9aa41bdf12f2ca1d85d052f347dd38d5 (diff)
Fix debuild warnings/errors
- Update .gitignore, do not place .gitignore into directories installed in bulk - Remove executable permissions and shebangs from the scripts that are supposed to be invoked only via ct-ng frontent; prepend them with $(bash). Despite what showSamples.sh said, it already has some bashisms. - Remove --with autotools-dev and override dh_update_autotools_config to avoid having config.{sub,guess} clobbered with older versions - Install bash completion where Debian (now) expects it - Update man page to use .\" as the comment delimiter, instead of undefined macro (."); also, minor text edits. - Install kconfig.mk without execute permission. - Remove shell wrappers from 170-localedef-fix-trampoline.patch, we do not use that for applying patches - Revoke execute permissions on 210-expat.sh - Get flags from dpkg-buildflags if available Signed-off-by: Alexey Neyman <stilor@att.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 869226c..4f7d3d3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -371,6 +371,8 @@ ACX_SET_KCONFIG_OPTION([svn])
AC_CHECK_PROGS([git], [git])
ACX_SET_KCONFIG_OPTION([git])
+AC_CHECK_PROGS([DPKG_BUILDFLAGS], [dpkg-buildflags])
+
#--------------------------------------------------------------------
# Now, for some fun...
#--------------------------------------------------------------------
@@ -465,5 +467,5 @@ AS_IF(
#--------------------------------------------------------------------
# Finally, generate the output file(s)
#--------------------------------------------------------------------
-AC_CONFIG_FILES([Makefile config/configure.in])
+AC_CONFIG_FILES([Makefile kconfig/Makefile config/configure.in])
AC_OUTPUT