summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlexey Neyman <stilor@att.net>2018-01-30 06:47:26 (GMT)
committerAlexey Neyman <stilor@att.net>2018-01-30 06:47:26 (GMT)
commit1c329c33bf4e1c6767454f98285e91ee19f1f724 (patch)
tree7862e1c9bfda8aabb266410a408b1a0bdef130b6 /configure.ac
parent30d741c1e5dbe03970b6c45f23a3b4ed697ae9f1 (diff)
Ncurses fixes for 6.1
- Update to 20180129 - Throw in --disable-db-install if database is disabled; otherwise 'make install' tries to run tic which is not built. - Select appropriate strip utility for the host; otherwise non-x86 architectures fail to install (unless --disable-stripping is also added) Signed-off-by: Alexey Neyman <stilor@att.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 17 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 24dcbcd..8ae98bf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -119,6 +119,22 @@ AC_DEFUN(
[AC_MSG_ERROR([Required tool not found: $2])])
])
+# Check if install(1) supports --strip-program=...
+AC_DEFUN(
+ [ACX_INSTALL_STRIP_PROGRAM],
+ [touch conftest
+ mkdir conftest.dir
+ AC_MSG_CHECKING([if install takes --strip-program option])
+ AS_IF([$INSTALL --strip-program=true -s conftest conftest.dir/conftest 2>/dev/null],
+ [install_with_strip_program=y
+ AC_MSG_RESULT([yes])],
+ [AC_MSG_RESULT([no])])
+ ACX_SET_KCONFIG_OPTION([install_with_strip_program])
+ rm -rf conftest.dir
+ rm -f conftest
+ ])
+
+
#--------------------------------------------------------------------
# Allow dummy --{en,dis}able-{static,shared}
AC_ARG_ENABLE(
@@ -159,6 +175,7 @@ AC_ARG_PROGRAM
ACX_WITH_DEPRECATED([install], [INSTALL])
AC_ARG_VAR([INSTALL], [Specify the full path to a BSD-compatible install])
AC_PROG_INSTALL
+ACX_INSTALL_STRIP_PROGRAM
ACX_WITH_DEPRECATED([grep], [GREP])
AC_ARG_VAR([GREP], [Specify the full path to GNU grep])