summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlexey Neyman <stilor@att.net>2017-04-22 19:28:50 (GMT)
committerAlexey Neyman <stilor@att.net>2017-04-22 19:28:50 (GMT)
commit2c0fb226419507583a736818346a7d6f07eba983 (patch)
tree8f9336eaa325a91a5219abb7420e4a00cd0ce80d /configure.ac
parent6f5afbdf82698ab0f91d5a36e7f171dd2829ec10 (diff)
Generate config/configure.in directly
from configure rather than substitute it from Makefile. Eventually we might want to get rid of configure.in completely, doing on-the-fly checks at the time of `ct-ng build`, but that is left for another day. Signed-off-by: Alexey Neyman <stilor@att.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 4 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index d10bf71..869226c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -65,10 +65,9 @@ AC_DEFUN(
AC_DEFUN(
[ACX_SET_KCONFIG_OPTION],
[AS_IF(
- [test -n "$$1"],
- [kconfig_options="$kconfig_options has_$1=y"],
- [kconfig_options="$kconfig_options has_$1"])
- ])
+ [test -n "$$1"],
+ [AC_SUBST([KCONFIG_$1], ["def_bool y"])],
+ [AC_SUBST([KCONFIG_$1], ["bool"])])])
# Check if a given program is available with a particular version.
# ACX_PROG_VERSION(VAR, HELP, PROG, SRCH, VERSION_CHECK[, CONFIG_OPT])
@@ -466,5 +465,5 @@ AS_IF(
#--------------------------------------------------------------------
# Finally, generate the output file(s)
#--------------------------------------------------------------------
-AC_CONFIG_FILES([Makefile])
+AC_CONFIG_FILES([Makefile config/configure.in])
AC_OUTPUT