summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlexey Neyman <stilor@att.net>2018-03-19 06:40:28 (GMT)
committerAlexey Neyman <stilor@att.net>2018-04-07 19:03:17 (GMT)
commit355f6f03fba92c71f9ff8d2e26985d2c1b7a0a0b (patch)
tree7c8a2752a950e332e6e6583c8e17a278aa8a105f /configure.ac
parentf45e29c5ca5c50bded67c295fb62e208365cf4d6 (diff)
Cannot ignore 'make install' with automake
Automake does not allow us to place the hooks before its generated actions, and does not allow us to check MAKECMDGOALS, and does not support a mechanism for disabling make install (such as noinst_SUBDIRS, requested a few times on automake mailing list). The only way I could preserve the current behavior is to have a GNUmakefile wrapper that will convert MAKECMDGOAL into a variable unknown to automake - which seems too convoluted a solution for the problem being solved. Hence the approach is to not override anything for --enable-local. It is now fully handled by selecting different values for CT_xxx_DIR in ct-ng.in; but at the build-system level, all the variables remain the same. We just don't support 'make install' in that case anymore; but the ct-ng in the working copy can be used after a regular 'make' (or 'make all'). Help message for --enable-local updated accordingly. Signed-off-by: Alexey Neyman <stilor@att.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 1 insertions, 17 deletions
diff --git a/configure.ac b/configure.ac
index c431f69..51e582e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -27,7 +27,7 @@ AC_ARG_ENABLE(
[local],
[AS_HELP_STRING(
[--enable-local],
- [do not install, and use current directory])])
+ [run ct-ng from the current directory; 'make install' unsupported])])
AC_SUBST([enable_local], [${enable_local:-no}])
# FIXME: I don't know why we have this. Will remove after the 1.24 release.
@@ -279,22 +279,6 @@ AS_IF(
[test -f version.sh -a -x version.sh],
[PACKAGE_VERSION=$(./version.sh "${PACKAGE_VERSION}")])
-# We are not installing dynamic libraries that need to be found by dynamic linker.
-# Install into a subdirectory.
-libdir=${libdir}/${PACKAGE_TARNAME}
-
-# Handle the local case
-AS_IF(
- [test "x$enable_local" = "xyes"],
- [AC_MSG_NOTICE([overiding all of --prefix and the likes, because --enable-local was set])
- prefix=$(pwd)
- exec_prefix="$prefix"
- bindir="$prefix"
- docdir="$prefix""/docs"
- pkgdatadir="$prefix"
- pkglibexecdir="$prefix/kconfig"
- mandir="$docdir"])
-
AC_CONFIG_FILES([
Makefile
paths.sh