summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlexey Neyman <stilor@att.net>2019-03-05 08:48:31 (GMT)
committerAlexey Neyman <stilor@att.net>2019-03-05 08:48:31 (GMT)
commit4ddad7b34f37f87e33e833f75a071c3775adc8cd (patch)
treeef3ad3d263a527f68feff64cc515acdbe6275776 /configure.ac
parentb3cce054ef381502af4f58105604081bf431ac9e (diff)
CentOS6 cannot use newer GDB releases
... unless one retrofits it with a decent compiler instead of stock GCC 4.4. While here, sync up the ax_*.m4 with autoconf-archive. Signed-off-by: Alexey Neyman <stilor@att.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 566b024..ae4a027 100644
--- a/configure.ac
+++ b/configure.ac
@@ -97,6 +97,9 @@ AC_PROG_YACC
AS_IF([test -z "$CC" -o -z "$CXX"],
[AC_MSG_ERROR([no suitable compiler found])])
+AX_CXX_COMPILE_STDCXX([11],, [optional])
+CTNG_SET_KCONFIG_OPTION([has_cxx11], [${HAVE_CXX11}])
+
# Check to see if the compiler can link statically
AC_MSG_CHECKING([if $CC can static link])
echo "int main() {}" | ${CC} -static -o /dev/null -xc - > /dev/null 2>&1