summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlexey Neyman <stilor@att.net>2018-02-17 18:37:18 (GMT)
committerAlexey Neyman <stilor@att.net>2018-04-07 19:03:17 (GMT)
commit66821508f4064904995189f4b46652eb6257b1ea (patch)
treebac14450df1be9d1d07759caad96115e7f4c1b0e /configure.ac
parent7655fc2a3c64fce46517d4a2af047d4c6e663f50 (diff)
Fix install --strip-program check after merge
Also, fix the use of AC_CACHE_CHECK in stat format checker. Signed-off-by: Alexey Neyman <stilor@att.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac28
1 files changed, 2 insertions, 26 deletions
diff --git a/configure.ac b/configure.ac
index e7feec5..02f91e0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -38,21 +38,6 @@ AC_ARG_ENABLE(
[--enable-static],
[build static libraries (deprecated, ignored)])])
-# Check if install(1) supports --strip-program=...
-AC_DEFUN(
- [ACX_INSTALL_STRIP_PROGRAM],
- [touch conftest
- mkdir conftest.dir
- AC_MSG_CHECKING([if install takes --strip-program option])
- AS_IF([$INSTALL --strip-program=true -s conftest conftest.dir/conftest 2>/dev/null],
- [install_with_strip_program=y
- AC_MSG_RESULT([yes])],
- [AC_MSG_RESULT([no])])
- ACX_SET_KCONFIG_OPTION([install_with_strip_program])
- rm -rf conftest.dir
- rm -f conftest
- ])
-
# Check for --build and --host...
AC_CANONICAL_BUILD
AC_CANONICAL_HOST
@@ -66,10 +51,7 @@ AC_ARG_PROGRAM
AC_PROG_MKDIR_P
AC_PROG_LN_S
-CTNG_WITH_DEPRECATED([install], [INSTALL])
-AC_ARG_VAR([INSTALL], [Specify the full path to a BSD-compatible install])
-AC_PROG_INSTALL
-ACX_INSTALL_STRIP_PROGRAM
+CTNG_PROG_INSTALL
CTNG_WITH_DEPRECATED([grep], [GREP])
AC_ARG_VAR([GREP], [Specify the full path to GNU grep])
@@ -140,13 +122,7 @@ AC_CHECK_PROGS([curl], [curl])
CTNG_SET_KCONFIG_OPTION([curl])
AC_SUBST([curl])
-CTNG_PROG_STAT(
- [CTNG_SET_KCONFIG_OPTION([stat_flavor_GNU], [y])
- CTNG_SET_KCONFIG_OPTION([stat_flavor_BSD])
- ],
- [CTNG_SET_KCONFIG_OPTION([stat_flavor_BSD], [y])
- CTNG_SET_KCONFIG_OPTION([stat_flavor_GNU])
- ])
+CTNG_PROG_STAT
CTNG_CPU_COUNT