summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBryan Hundven <bryanhundven@gmail.com>2015-11-15 06:55:40 (GMT)
committerBryan Hundven <bryanhundven@gmail.com>2015-11-15 07:14:44 (GMT)
commit6c49a232a81cf4f4f22a13b13e91af74e7edab32 (patch)
treeb7aaf31ab91e9770018e233844de45a684dd1bfb /configure.ac
parent80e8c1135d7a8ab5875b9e616cec8f07f717504b (diff)
configure: Correctly search for tinfo for kconfig
I previously thought that tinfo could only be a link to libncurses in modern ncurses installations. I was wrong. Now we check for ncurses, then check for tinfo. If tinfo is a link to ncurses, it is then not required to link against. But if libtinfo is providing tgetent, and not libncurses, then we must add it to LIBS as well. Also, kconfig shouldn't hardcode -lncurses, it should use what is in $(LIBS). Signed-off-by: Bryan Hundven <bryanhundven@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 3 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index f5c5e10..4f0b428 100644
--- a/configure.ac
+++ b/configure.ac
@@ -339,15 +339,6 @@ LIBS=$SAVE_LIBS
AC_SUBST([INTL_LIBS])
#----------------------------------------
-# Check for tinfo, for the kconfig frontends
-AC_SEARCH_LIBS(
- [tigetnum],
- [tinfo],
- [ac_ct_tinfo_lib_found=yes; break])
-AS_IF(
- [test -z "$ac_ct_tinfo_lib_found"],
- [AC_MSG_ERROR([could not find tinfo library, required for the kconfig frontends])])
-
# Check for ncurses, for the kconfig frontends
AC_SUBST([ac_ct_curses_hdr])
AC_CHECK_HEADERS(
@@ -363,6 +354,9 @@ AC_SEARCH_LIBS(
AS_IF(
[test -z "$ac_ct_curses_lib_found"],
[AC_MSG_ERROR([could not find curses library, required for the kconfig frontends])])
+AC_SEARCH_LIBS(
+ [tgetent],
+ [termcap tinfo ncursesw ncurses curses])
#--------------------------------------------------------------------
# Lastly, take care of crosstool-NG internal values