summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlexey Neyman <stilor@att.net>2016-11-21 20:09:54 (GMT)
committerAlexey Neyman <stilor@att.net>2016-11-22 07:03:03 (GMT)
commit87bfd55b3b5329c7f306fa291ca5e0950a2c9da1 (patch)
treeaa666685885104ed985b4c743ad3222968e7ae54 /configure.ac
parent488b27f58bfdb3c9c523448acfa17b51325fec03 (diff)
Give companion tools some love.
Allow selection of make/m4/... version. Support imports of new versions via addToolVersion.sh. Import newest versions of the companion tools. One non-trivial change is the handling of make versions. Existing code was not handling make companion tool as described (see the previous commit). However, since most modern systems have make 4.x, that previous commit made crosstool-ng always build make as a companion tool. This traces back to the commit dd15c93 from 2014. That commit's log message says that actually it was 3.81 which broke the build for certain component (it was originally breaking eglibc, but I noticed it was breaking current glibc on powerpc64), and introduced an option to force using 3.81 by "components that really need it". It looks like in 2.5 years we haven't seen any such components that really need make 3.81, and (given that make has already had a few releases since 3.81) we're unlikely to see them in the future. Hence, the configure check is changed from "exactly 3.81" to "3.81 or newer". In its current form, configure will accept make 3.80+, and will not require make as a companion tool for 3.81+. We might want to bump the latter check to even newer version given the claim from dd15c93. Killed COMP_TOOLS_make_3_81_NEEDED. Anyway, I retained 3.81 just in case; ditto for m4 1.14.3, autoconf 2.65 and automake 1.11.1. Signed-off-by: Alexey Neyman <stilor@att.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 8 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 8651015..492d315 100644
--- a/configure.ac
+++ b/configure.ac
@@ -241,19 +241,21 @@ AC_CACHE_CHECK([for GNU make >= 3.80], [ac_cv_path_MAKE],
AC_SUBST([MAKE], [$ac_cv_path_MAKE])
AC_PROG_MAKE_SET
-# Check for GNU make 3.81 exactly, otherwise
+# Check for GNU make 3.81 or newer, otherwise
# it will be built as a companion tool.
-AC_MSG_CHECKING([for make 3.81])
+AC_MSG_CHECKING([if make is 3.81 or newer])
AS_IF(
- [test "$MAKE_ver" = "GNU Make 3.81"],
- [make381="y"
+ [[MAKE_ver2=$(echo "$MAKE_ver" \
+ |$EGREP '^GNU Make (3.81|3.9[0-9]|[4-9])')
+ test -n "$MAKE_ver2"]],
+ [make_3_81_or_newer="y"
AC_MSG_RESULT([yes])
],
- [make381=
+ [make_3_81_or_newer=
AC_MSG_RESULT([no])
]
)
-ACX_SET_KCONFIG_OPTION([make381])
+ACX_SET_KCONFIG_OPTION([make_3_81_or_newer])
#----------------------------------------
# Check for libtool >= 1.5.26