summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorYann E. MORIN" <yann.morin.1998@anciens.enib.fr>2012-01-16 23:37:59 (GMT)
committerYann E. MORIN" <yann.morin.1998@anciens.enib.fr>2012-01-16 23:37:59 (GMT)
commit887eefec342c052f108973176b414b761e06d0af (patch)
tree530370a676a5d256ef4724b092a2ce9abda85caa /configure.ac
parentb86899a341a756088e065edbf9c63c6187ff3fb6 (diff)
configure: also detect plain grep
We need just 'grep', and we need to be able to call it with 'grep -E'. Check for 'grep', and bailout if egrep != grep -E Signed-off-by: "Yann E. MORIN" <yann.morin.1998@anciens.enib.fr>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 51ce527..7f49c0d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -91,7 +91,11 @@ AC_ARG_PROGRAM
# just what I seem to experience...)
#---------------------------------------------------------------------
AC_PROG_INSTALL
+AC_PROG_GREP
AC_PROG_EGREP
+AS_IF(
+ [test ! "$EGREP" = "$GREP -E"],
+ [AC_MSG_ERROR([egrep is not $GREP -E])])
AC_CACHE_VAL([ac_cv_path_SED],
[AC_ARG_WITH([sed],
AS_HELP_STRING([--with-sed=PATH],