summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlexey Neyman <stilor@att.net>2018-04-03 07:01:17 (GMT)
committerAlexey Neyman <stilor@att.net>2018-04-07 19:03:17 (GMT)
commitbb6c97551f7cfafea811367de0a6f382d9aec36b (patch)
tree15291810af95d2e19be89a14be669a532f69c31b /configure.ac
parent56d785bd006ab823caf39fc16e2ae6833ef2d780 (diff)
User manual installation
... when running from a release tarball. Signed-off-by: Alexey Neyman <stilor@att.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 10 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 51e582e..c7b6f5a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4,7 +4,7 @@
AC_PREREQ([2.67])
# FIXME Temporary hack until the next release (we'll switch to plain numeric tags then)
-# TBD need to quote sed expression
+# FIXME need to quote sed expression
AC_INIT(
[crosstool-NG],
[m4_esyscmd_s([git describe --always --dirty | sed s,^crosstool-ng-,,])],
@@ -14,13 +14,16 @@ AC_INIT(
AC_CONFIG_AUX_DIR([scripts])
AC_CONFIG_MACRO_DIR([m4])
-# TBD try to use gnu strictness? Just add the missing files?
+# FIXME try to use gnu strictness? Just add the missing files?
# Set automake defaults:
# - Tarballs are compressed with xz and bzip2
# - Object files are generated in a subdirectory (new default in automake)
# - Request new tar format (old, tar-v7, breaks on long paths we have)
AM_INIT_AUTOMAKE([-Wall -Werror foreign no-dist-gzip dist-xz dist-bzip2 subdir-objects tar-pax])
+# Safety check per autoconf best practices
+AC_CONFIG_SRCDIR([ct-ng.in])
+
#--------------------------------------------------------------------
# Allow dummy --{en,dis}able-{static,shared}
AC_ARG_ENABLE(
@@ -274,6 +277,11 @@ AH_BOTTOM([
AX_BUILD_DATE_EPOCH(DATE, [%c])
AC_SUBST([DATE])
+AM_CONDITIONAL([INSTALL_USER_MANUAL], [test ! -f "${srcdir}/docs/MANUAL_ONLINE"])
+AC_MSG_CHECKING([if the manual needs to be installed])
+AM_COND_IF([INSTALL_USER_MANUAL], [AC_MSG_RESULT([yes])], [AC_MSG_RESULT([no])])
+
+# FIXME Retire? We don't want to debug a version that has been mislabeled by a user
# Decorate the version string per user-supplied version.sh, if any
AS_IF(
[test -f version.sh -a -x version.sh],