summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKeith Packard <keithp@keithp.com>2020-08-16 19:37:45 (GMT)
committerKeith Packard <keithp@keithp.com>2020-09-01 16:42:53 (GMT)
commitc15de32ec64e398a97430a244e7510ccf8600116 (patch)
tree97cc9dcc8c49cd896244604e03b5614831fc0351 /configure.ac
parent4e5bc43627582b11f11ebc1cedcfd1016f39c60e (diff)
Add picolibc support [v2]
This adds support for using picolibc instead of newlib on embedded systems. Signed-off-by: Keith Packard <keithp@keithp.com> v2: Add check for meson and ninja Sync option default values with current picolibc defaults Remove xtensa sys header file install as those aren't in picolibc
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 096ebb7..8151737 100644
--- a/configure.ac
+++ b/configure.ac
@@ -152,6 +152,14 @@ AC_CHECK_PROGS([curl], [curl])
CTNG_SET_KCONFIG_OPTION([curl])
AC_SUBST([curl])
+AC_CHECK_PROGS([meson], [meson])
+CTNG_SET_KCONFIG_OPTION([meson])
+AC_SUBST([meson])
+
+AC_CHECK_PROGS([ninja], [ninja])
+CTNG_SET_KCONFIG_OPTION([ninja])
+AC_SUBST([ninja])
+
CTNG_CPU_COUNT
CTNG_PATH_TOOL_REQ([PATCH], [gpatch patch], [patch])