summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlexey Neyman <stilor@att.net>2017-10-05 07:09:22 (GMT)
committerAlexey Neyman <stilor@att.net>2018-04-07 19:02:33 (GMT)
commitd401afbddaae56093cce388e62f7ba4d9d68a327 (patch)
tree5b1c7fdc13dd2ade2dbe8576045427e072d1f4d1 /configure.ac
parent1ce2eab963a004ba352a5cea800e2765a7c6affd (diff)
Get rid of sub{lib,doc}dir
They don't make sense - using same ct-ng won't work with different versions, so they cannot coexist in the same prefix. Also localize other configure variables so that their usage is easier to track. Signed-off-by: Alexey Neyman <stilor@att.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 5 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 8fa0e33..72198d1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -301,9 +301,11 @@ AS_IF(
[test -f version.sh -a -x version.sh],
[PACKAGE_VERSION=$(./version.sh "${PACKAGE_VERSION}")])
+# We are not installing dynamic libraries that need to be found by dynamic linker.
+# Install into a subdirectory.
+libdir=${libdir}/${PACKAGE_TARNAME}
+
# Handle the local case
-AC_SUBST([sublibdir])
-AC_SUBST([subdocdir])
AS_IF(
[test "x$enable_local" = "xyes"],
[AC_MSG_NOTICE([overiding all of --prefix and the likes, because --enable-local was set])
@@ -311,13 +313,9 @@ AS_IF(
exec_prefix="$prefix"
bindir="$prefix"
libdir="$prefix"
- sublibdir=""
docdir="$prefix""/docs"
- subdocdir=""
datarootdir="$prefix"
- mandir="$docdir"],
- [sublibdir="/\${VERSION}"
- subdocdir="/\${VERSION}"])
+ mandir="$docdir"])
AC_CONFIG_FILES([
Makefile