summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBryan Hundven <bryanhundven@gmail.com>2015-11-14 22:27:50 (GMT)
committerBryan Hundven <bryanhundven@gmail.com>2015-11-14 22:29:11 (GMT)
commitebb0df619e06fef22608c9d4e5b4a7e0f7c8b44d (patch)
treeb1ca8e8134d9533b818190abd3b0cbcef6897b22 /configure.ac
parente78251b75158689ace2194e8c87aa7b7bb5ec951 (diff)
configure: Check for libtinfo.so
While usually distributed with ncurses, some distributions distribute this library separately. Check to make sure it is installed. This closes #241 Signed-off-by: Bryan Hundven <bryanhundven@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b922482..9c8c098 100644
--- a/configure.ac
+++ b/configure.ac
@@ -339,6 +339,15 @@ LIBS=$SAVE_LIBS
AC_SUBST([INTL_LIBS])
#----------------------------------------
+# Check for tinfo, for the kconfig frontends
+AC_SEARCH_LIBS(
+ [tigetnum],
+ [tinfo],
+ [ac_ct_tinfo_lib_found=yes; break])
+AS_IF(
+ [test -z "$ac_ct_tinfo_lib_found"],
+ [AC_MSG_ERROR([could not find tinfo library, required for the kconfig frontends])])
+
# Check for ncurses, for the kconfig frontends
AC_SUBST([ac_ct_curses_hdr])
AC_CHECK_HEADERS(