summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChris Packham <judge.packham@gmail.com>2021-11-14 08:24:03 (GMT)
committerChris Packham <judge.packham@gmail.com>2021-11-30 06:56:44 (GMT)
commitf441a6bf0dc7031145a1383e8037daf48f7c60ca (patch)
treef2ca720c4dbf6c5f5a0c7a27242f5b9b864d7a53 /configure.ac
parent4dc9d643f94720bb11a7b4fa0c39729a684be5bb (diff)
linux: Add dependency on rsync for Linux >= 5.3
As of Linux v5.3 rsync is used as part of the build process. Add Linux 5.3 as a milestone, configure detection of rsync and a dependency on rsync for Linux 5.3 and newer. Add a comment in so that users can tell why they can't select a newer version. Fixes #1628 Signed-off-by: Chris Packham <judge.packham@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c4964df..8736fe1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -161,6 +161,10 @@ AC_CHECK_PROGS([ninja], [ninja])
CTNG_SET_KCONFIG_OPTION([ninja])
AC_SUBST([ninja])
+AC_CHECK_PROGS([rsync], [rsync])
+CTNG_SET_KCONFIG_OPTION([rsync])
+AC_SUBST([rsync])
+
CTNG_CPU_COUNT
CTNG_PATH_TOOL_REQ([PATCH], [gpatch patch], [patch])