summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorChris Packham <chris.packham@alliedtelesis.co.nz>2016-02-24 07:18:07 (GMT)
committerChris Packham <chris.packham@alliedtelesis.co.nz>2017-05-29 00:36:45 (GMT)
commit5f1acaa0794bac4c3a19baa3fcbcfc0e0e8ad1de (patch)
tree71fb51f2d6f231fec55fcee9ffd39e0e05c154d4 /debian/rules
parent368a0169a27313cca60cf7d7358b6f3ef12122e4 (diff)
debian: update packaging
Support building in tree and from a released tarball by optionally running ./bootstrap. Fix some issues reported by lintian. -E: crosstool-ng changes: bad-distribution-in-changes-file unstable -E: crosstool-ng source: build-depends-on-essential-package-without-using-version build-depends: gzip -E: crosstool-ng source: build-depends-on-essential-package-without-using-version build-depends: tar -W: crosstool-ng source: syntax-error-in-dep5-copyright line 14: Cannot parse line "Unless otherwise stated in individual files, this work is licensed to you under" -E: crosstool-ng: copyright-should-refer-to-common-license-file-for-lgpl -E: crosstool-ng: description-starts-with-package-name -E: crosstool-ng: section-is-dh_make-template -E: crosstool-ng: depends-on-obsolete-package depends: texi2html Signed-off-by: Chris Packham <chris.packham@alliedtelesis.co.nz>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules3
1 files changed, 2 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 7dff29c..9315284 100755
--- a/debian/rules
+++ b/debian/rules
@@ -23,7 +23,8 @@ include /usr/share/dpkg/default.mk
# Make sure we call ./bootstrap before running dh_auto_configure
override_dh_auto_configure:
- ./bootstrap && dh_auto_configure
+ test -e configure || ./bootstrap
+ dh_auto_configure
#Make sure to include bash completion file in the package
override_dh_auto_install: