summaryrefslogtreecommitdiff
path: root/packages/binutils/2.35.1/0004-Dont-link-to-libfl-as-its-unnecessary.patch
diff options
context:
space:
mode:
authorChris Packham <judge.packham@gmail.com>2020-09-27 02:22:37 (GMT)
committerGitHub <noreply@github.com>2020-09-27 02:22:37 (GMT)
commitb3ed2c40d37cf7d5c2143307286f5d9557ed2df3 (patch)
tree836107b57162b18c301f430742a12c80c5231579 /packages/binutils/2.35.1/0004-Dont-link-to-libfl-as-its-unnecessary.patch
parentea386017b60b38b17b13044544eeb268c1c3ee28 (diff)
parent04b318a48b33f1342129788adf04bbd2067198ce (diff)
Merge pull request #1391 from egtvedt/add-binutils-2.35.1
binutils: add version 2.35.1
Diffstat (limited to 'packages/binutils/2.35.1/0004-Dont-link-to-libfl-as-its-unnecessary.patch')
-rw-r--r--packages/binutils/2.35.1/0004-Dont-link-to-libfl-as-its-unnecessary.patch105
1 files changed, 105 insertions, 0 deletions
diff --git a/packages/binutils/2.35.1/0004-Dont-link-to-libfl-as-its-unnecessary.patch b/packages/binutils/2.35.1/0004-Dont-link-to-libfl-as-its-unnecessary.patch
new file mode 100644
index 0000000..02efa21
--- /dev/null
+++ b/packages/binutils/2.35.1/0004-Dont-link-to-libfl-as-its-unnecessary.patch
@@ -0,0 +1,105 @@
+---
+ binutils/configure | 3 +++
+ binutils/configure.ac | 3 +++
+ gas/configure | 3 +++
+ gas/configure.ac | 3 +++
+ ld/configure | 3 +++
+ ld/configure.ac | 3 +++
+ 6 files changed, 18 insertions(+)
+
+--- a/binutils/configure
++++ b/binutils/configure
+@@ -12570,6 +12570,7 @@ fi
+ done
+ test -n "$YACC" || YACC="yacc"
+
++save_LIBS=$LIBS
+ for ac_prog in flex lex
+ do
+ # Extract the first word of "$ac_prog", so it can be a program name with args.
+@@ -12733,6 +12734,8 @@ esac
+ if test "$LEX" = :; then
+ LEX=${am_missing_run}flex
+ fi
++LIBS=$save_LIBS
++LEXLIB=
+
+ ALL_LINGUAS="bg ca da es fi fr hr id it ja pt ro ru rw sk sr sv tr uk vi zh_CN zh_TW"
+ # If we haven't got the data from the intl directory,
+--- a/binutils/configure.ac
++++ b/binutils/configure.ac
+@@ -95,7 +95,10 @@ if test -z "$host" ; then
+ fi
+
+ AC_PROG_YACC
++save_LIBS=$LIBS
+ AM_PROG_LEX
++LIBS=$save_LIBS
++LEXLIB=
+
+ ALL_LINGUAS="bg ca da es fi fr hr id it ja pt ro ru rw sk sr sv tr uk vi zh_CN zh_TW"
+ ZW_GNU_GETTEXT_SISTER_DIR
+--- a/gas/configure
++++ b/gas/configure
+@@ -13519,6 +13519,7 @@ fi
+ done
+ test -n "$YACC" || YACC="yacc"
+
++save_LIBS=$LIBS
+ for ac_prog in flex lex
+ do
+ # Extract the first word of "$ac_prog", so it can be a program name with args.
+@@ -13682,6 +13683,8 @@ esac
+ if test "$LEX" = :; then
+ LEX=${am_missing_run}flex
+ fi
++LIBS=$save_LIBS
++LEXLIB=
+
+ ALL_LINGUAS="es fi fr id ja ru rw sv tr uk zh_CN"
+ # If we haven't got the data from the intl directory,
+--- a/gas/configure.ac
++++ b/gas/configure.ac
+@@ -924,7 +924,10 @@ AC_DEFINE_UNQUOTED(TARGET_VENDOR, "${tar
+ AC_DEFINE_UNQUOTED(TARGET_OS, "${target_os}", [Target OS.])
+
+ AC_PROG_YACC
++save_LIBS=$LIBS
+ AM_PROG_LEX
++LIBS=$save_LIBS
++LEXLIB=
+
+ ALL_LINGUAS="es fi fr id ja ru rw sv tr uk zh_CN"
+ ZW_GNU_GETTEXT_SISTER_DIR
+--- a/ld/configure
++++ b/ld/configure
+@@ -16584,6 +16584,7 @@ fi
+ done
+ test -n "$YACC" || YACC="yacc"
+
++save_LIBS=$LIBS
+ for ac_prog in flex lex
+ do
+ # Extract the first word of "$ac_prog", so it can be a program name with args.
+@@ -16747,6 +16748,8 @@ esac
+ if test "$LEX" = :; then
+ LEX=${am_missing_run}flex
+ fi
++LIBS=$save_LIBS
++LEXLIB=
+
+
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking whether to enable maintainer-specific portions of Makefiles" >&5
+--- a/ld/configure.ac
++++ b/ld/configure.ac
+@@ -258,7 +258,10 @@ AM_PO_SUBDIRS
+ AC_EXEEXT
+
+ AC_PROG_YACC
++save_LIBS=$LIBS
+ AM_PROG_LEX
++LIBS=$save_LIBS
++LEXLIB=
+
+ AM_MAINTAINER_MODE
+ AM_CONDITIONAL(GENINSRC_NEVER, false)