summaryrefslogtreecommitdiff
path: root/packages/binutils/2.38/0003-Dont-link-to-libfl-as-its-unnecessary.patch
diff options
context:
space:
mode:
authorHans-Christian Noren Egtvedt <hegtvedt@cisco.com>2022-02-09 18:00:29 (GMT)
committerChris Packham <judge.packham@gmail.com>2022-02-13 07:47:12 (GMT)
commitba680a3e5b8c62a7c1554e71f6d09903dac95a2f (patch)
tree7ae47b96f1061863b18f0a1e5f84a1d31cafc10e /packages/binutils/2.38/0003-Dont-link-to-libfl-as-its-unnecessary.patch
parentc5565f175aa0d5b25d47c839610bab6f9ee999a1 (diff)
packages/binutils: add binutils-2.38
Binutils version 2.38 has been released https://www.phoronix.com/scan.php?page=news_item&px=GNU-Binutils-2.38 https://sourceware.org/pipermail/binutils/2022-February/119721.html Patches 0000 to 0008 from binutils-2.37 applied clean, so forward ported them. The following patches are now applied from upstream, hence dropped: 0010-change-uint-to-unsigned.patch 0011-bfd-close-the-file-descriptor-if-there-is-no-archive-fd.patch 0012-pr28391-strip-objcopy-preserve-dates-a-cannot-set-time.patch 0013-ld-pru-fix-resource_table-output-section-alignment.patch 0014-pr28422-build_id-use-after-free.patch 0015-pr28459-readelf-issues-bogus-warning.patch 0016-pr28417-std-string-no-longer-allows-accepting-nullptr_t.patch 0017-pr28540-segmentation-fault-on-NULL-byte_get.patch 0018-gold-place-note-gnu-property-section-before-other-note-sections.patch 0019-waddress-warning-in-ldelf.c.patch Signed-off-by: Hans-Christian Noren Egtvedt <hegtvedt@cisco.com>
Diffstat (limited to 'packages/binutils/2.38/0003-Dont-link-to-libfl-as-its-unnecessary.patch')
-rw-r--r--packages/binutils/2.38/0003-Dont-link-to-libfl-as-its-unnecessary.patch105
1 files changed, 105 insertions, 0 deletions
diff --git a/packages/binutils/2.38/0003-Dont-link-to-libfl-as-its-unnecessary.patch b/packages/binutils/2.38/0003-Dont-link-to-libfl-as-its-unnecessary.patch
new file mode 100644
index 0000000..f785f03
--- /dev/null
+++ b/packages/binutils/2.38/0003-Dont-link-to-libfl-as-its-unnecessary.patch
@@ -0,0 +1,105 @@
+---
+ binutils/configure | 3 +++
+ binutils/configure.ac | 3 +++
+ gas/configure | 3 +++
+ gas/configure.ac | 3 +++
+ ld/configure | 3 +++
+ ld/configure.ac | 3 +++
+ 6 files changed, 18 insertions(+)
+
+--- a/binutils/configure
++++ b/binutils/configure
+@@ -12273,6 +12273,7 @@
+ done
+ test -n "$YACC" || YACC="yacc"
+
++save_LIBS=$LIBS
+ for ac_prog in flex lex
+ do
+ # Extract the first word of "$ac_prog", so it can be a program name with args.
+@@ -12436,6 +12437,8 @@
+ if test "$LEX" = :; then
+ LEX=${am_missing_run}flex
+ fi
++LIBS=$save_LIBS
++LEXLIB=
+
+ ALL_LINGUAS="bg ca da es fi fr hr id it ja pt ro ru rw sk sr sv tr uk vi zh_CN zh_TW"
+ # If we haven't got the data from the intl directory,
+--- a/binutils/configure.ac
++++ b/binutils/configure.ac
+@@ -137,7 +137,10 @@
+ fi
+
+ AC_PROG_YACC
++save_LIBS=$LIBS
+ AM_PROG_LEX
++LIBS=$save_LIBS
++LEXLIB=
+
+ ALL_LINGUAS="bg ca da es fi fr hr id it ja pt ro ru rw sk sr sv tr uk vi zh_CN zh_TW"
+ ZW_GNU_GETTEXT_SISTER_DIR
+--- a/gas/configure
++++ b/gas/configure
+@@ -12930,6 +12930,7 @@
+ done
+ test -n "$YACC" || YACC="yacc"
+
++save_LIBS=$LIBS
+ for ac_prog in flex lex
+ do
+ # Extract the first word of "$ac_prog", so it can be a program name with args.
+@@ -13093,6 +13094,8 @@
+ if test "$LEX" = :; then
+ LEX=${am_missing_run}flex
+ fi
++LIBS=$save_LIBS
++LEXLIB=
+
+ ALL_LINGUAS="es fi fr id ja ru rw sv tr uk zh_CN"
+ # If we haven't got the data from the intl directory,
+--- a/gas/configure.ac
++++ b/gas/configure.ac
+@@ -937,7 +937,10 @@
+ AC_DEFINE_UNQUOTED(TARGET_OS, "${target_os}", [Target OS.])
+
+ AC_PROG_YACC
++save_LIBS=$LIBS
+ AM_PROG_LEX
++LIBS=$save_LIBS
++LEXLIB=
+
+ ALL_LINGUAS="es fi fr id ja ru rw sv tr uk zh_CN"
+ ZW_GNU_GETTEXT_SISTER_DIR
+--- a/ld/configure
++++ b/ld/configure
+@@ -16132,6 +16132,7 @@
+ done
+ test -n "$YACC" || YACC="yacc"
+
++save_LIBS=$LIBS
+ for ac_prog in flex lex
+ do
+ # Extract the first word of "$ac_prog", so it can be a program name with args.
+@@ -16295,6 +16296,8 @@
+ if test "$LEX" = :; then
+ LEX=${am_missing_run}flex
+ fi
++LIBS=$save_LIBS
++LEXLIB=
+
+
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking whether to enable maintainer-specific portions of Makefiles" >&5
+--- a/ld/configure.ac
++++ b/ld/configure.ac
+@@ -289,7 +289,10 @@
+ AC_EXEEXT
+
+ AC_PROG_YACC
++save_LIBS=$LIBS
+ AM_PROG_LEX
++LIBS=$save_LIBS
++LEXLIB=
+
+ AM_MAINTAINER_MODE
+ AM_CONDITIONAL(GENINSRC_NEVER, false)