summaryrefslogtreecommitdiff
path: root/packages/gdb/11.1/0002-allow-android.patch
diff options
context:
space:
mode:
authorChris Packham <judge.packham@gmail.com>2021-09-14 09:31:38 (GMT)
committerChris Packham <judge.packham@gmail.com>2021-09-19 07:50:29 (GMT)
commit68088f65c66790c1a5920e67e7e34d9f77e5a20f (patch)
tree7ed5bd7fb084879f1750b3ad378c404b9e6a9997 /packages/gdb/11.1/0002-allow-android.patch
parent4b2b610b9a64cef9208912a0858a9087cf089ea4 (diff)
gdb: Add gdb-11.1
Drop the uclibc-no-gettimeofday-clobber patch as it no longer applies. The arc patches are all upstream. Signed-off-by: Chris Packham <judge.packham@gmail.com>
Diffstat (limited to 'packages/gdb/11.1/0002-allow-android.patch')
-rw-r--r--packages/gdb/11.1/0002-allow-android.patch45
1 files changed, 45 insertions, 0 deletions
diff --git a/packages/gdb/11.1/0002-allow-android.patch b/packages/gdb/11.1/0002-allow-android.patch
new file mode 100644
index 0000000..d6c5869
--- /dev/null
+++ b/packages/gdb/11.1/0002-allow-android.patch
@@ -0,0 +1,45 @@
+---
+ gdbserver/configure | 11 -----------
+ gdbserver/configure.ac | 11 -----------
+ 2 files changed, 22 deletions(-)
+
+--- a/gdbserver/configure
++++ b/gdbserver/configure
+@@ -10028,17 +10028,6 @@
+
+
+ case "${target}" in
+- *-android*)
+- # Starting with NDK version 9, <elf.h> actually includes definitions
+- # of Elf32_auxv_t and Elf64_auxv_t. But sadly, <elf.h> includes
+- # <sys/exec_elf.h> which defines some of the ELF types incorrectly,
+- # leading to conflicts with the defintions from <linux/elf.h>.
+- # This makes it impossible for us to include both <elf.h> and
+- # <linux/elf.h>, which means that, in practice, we do not have
+- # access to Elf32_auxv_t and Elf64_auxv_t on this platform.
+- # Therefore, do not try to auto-detect availability, as it would
+- # get it wrong on this platform.
+- ;;
+ *)
+ ac_fn_c_check_type "$LINENO" "Elf32_auxv_t" "ac_cv_type_Elf32_auxv_t" "#include <elf.h>
+
+--- a/gdbserver/configure.ac
++++ b/gdbserver/configure.ac
+@@ -171,17 +171,6 @@
+ ])
+
+ case "${target}" in
+- *-android*)
+- # Starting with NDK version 9, <elf.h> actually includes definitions
+- # of Elf32_auxv_t and Elf64_auxv_t. But sadly, <elf.h> includes
+- # <sys/exec_elf.h> which defines some of the ELF types incorrectly,
+- # leading to conflicts with the defintions from <linux/elf.h>.
+- # This makes it impossible for us to include both <elf.h> and
+- # <linux/elf.h>, which means that, in practice, we do not have
+- # access to Elf32_auxv_t and Elf64_auxv_t on this platform.
+- # Therefore, do not try to auto-detect availability, as it would
+- # get it wrong on this platform.
+- ;;
+ *)
+ AC_CHECK_TYPES([Elf32_auxv_t, Elf64_auxv_t], [], [],
+ #include <elf.h>