summaryrefslogtreecommitdiff
path: root/packages/gdb/8.0.1
diff options
context:
space:
mode:
authorAlexey Neyman <stilor@att.net>2017-12-02 20:44:39 (GMT)
committerAlexey Neyman <stilor@att.net>2017-12-02 20:44:39 (GMT)
commit98bc4decdeab1361bdc585c86591718fb08c8ffb (patch)
tree4e048ed57988306696efa3c5b81a80d48030e913 /packages/gdb/8.0.1
parent2a1935f3ad41d360dd3d96a1b0486083293651dd (diff)
Run all patches through renumbering and update
Signed-off-by: Alexey Neyman <stilor@att.net>
Diffstat (limited to 'packages/gdb/8.0.1')
-rw-r--r--packages/gdb/8.0.1/0000-musl_fix.patch (renamed from packages/gdb/8.0.1/100-musl_fix.patch)7
-rw-r--r--packages/gdb/8.0.1/0001-uclibc-no-gettimeofday-clobber.patch (renamed from packages/gdb/8.0.1/101-uclibc-no-gettimeofday-clobber.patch)19
-rw-r--r--packages/gdb/8.0.1/0002-xtensa-make-sure-ar_base-is-initialized.patch (renamed from packages/gdb/8.0.1/111-xtensa-make-sure-ar_base-is-initialized.patch)9
-rw-r--r--packages/gdb/8.0.1/0003-WIP-end-of-prologue-detection-hack.patch (renamed from packages/gdb/8.0.1/112-WIP-end-of-prologue-detection-hack.patch)9
-rw-r--r--packages/gdb/8.0.1/0004-allow-android.patch (renamed from packages/gdb/8.0.1/200-allow-android.patch)19
5 files changed, 32 insertions, 31 deletions
diff --git a/packages/gdb/8.0.1/100-musl_fix.patch b/packages/gdb/8.0.1/0000-musl_fix.patch
index c0c1e0a..6829780 100644
--- a/packages/gdb/8.0.1/100-musl_fix.patch
+++ b/packages/gdb/8.0.1/0000-musl_fix.patch
@@ -1,3 +1,8 @@
+---
+ gdb/linux-nat.c | 5 +++++
+ gdb/stopcode.h | 4 ++++
+ 2 files changed, 9 insertions(+)
+
--- a/gdb/linux-nat.c
+++ b/gdb/linux-nat.c
@@ -17,6 +17,7 @@
@@ -8,7 +13,7 @@
#include "defs.h"
#include "inferior.h"
#include "infrun.h"
-@@ -73,6 +74,10 @@
+@@ -71,6 +72,10 @@
#define SPUFS_MAGIC 0x23c9b64e
#endif
diff --git a/packages/gdb/8.0.1/101-uclibc-no-gettimeofday-clobber.patch b/packages/gdb/8.0.1/0001-uclibc-no-gettimeofday-clobber.patch
index cd7a4c6..01fdfa1 100644
--- a/packages/gdb/8.0.1/101-uclibc-no-gettimeofday-clobber.patch
+++ b/packages/gdb/8.0.1/0001-uclibc-no-gettimeofday-clobber.patch
@@ -6,10 +6,14 @@ gdb-native step otherwise fails when linking the libinproctrace.so
Signed-off-by: Joachim Nilsson <troglobit@gmail.com>
Signed-off-by: Alexey Neyman <stilor@att.net>
-diff -urpN gdb-7.12.orig/gdb/gnulib/configure gdb-7.12/gdb/gnulib/configure
---- gdb-7.12.orig/gdb/gnulib/configure 2017-01-13 13:42:11.773027566 -0800
-+++ gdb-7.12/gdb/gnulib/configure 2017-01-13 13:44:32.518082618 -0800
-@@ -13522,6 +13522,7 @@ else
+---
+ gdb/gnulib/configure | 1 +
+ gdb/gnulib/import/m4/gettimeofday.m4 | 1 +
+ 2 files changed, 2 insertions(+)
+
+--- a/gdb/gnulib/configure
++++ b/gdb/gnulib/configure
+@@ -13868,6 +13868,7 @@
case "$host_os" in
# Guess all is fine on glibc systems.
*-gnu*) gl_cv_func_gettimeofday_clobber="guessing no" ;;
@@ -17,10 +21,9 @@ diff -urpN gdb-7.12.orig/gdb/gnulib/configure gdb-7.12/gdb/gnulib/configure
# If we don't know, assume the worst.
*) gl_cv_func_gettimeofday_clobber="guessing yes" ;;
esac
-diff -urpN gdb-7.12.orig/gdb/gnulib/import/m4/gettimeofday.m4 gdb-7.12/gdb/gnulib/import/m4/gettimeofday.m4
---- gdb-7.12.orig/gdb/gnulib/import/m4/gettimeofday.m4 2017-01-13 13:42:11.777027595 -0800
-+++ gdb-7.12/gdb/gnulib/import/m4/gettimeofday.m4 2017-01-13 13:43:55.781797640 -0800
-@@ -111,6 +111,7 @@ AC_DEFUN([gl_FUNC_GETTIMEOFDAY_CLOBBER],
+--- a/gdb/gnulib/import/m4/gettimeofday.m4
++++ b/gdb/gnulib/import/m4/gettimeofday.m4
+@@ -111,6 +111,7 @@
case "$host_os" in
# Guess all is fine on glibc systems.
*-gnu*) gl_cv_func_gettimeofday_clobber="guessing no" ;;
diff --git a/packages/gdb/8.0.1/111-xtensa-make-sure-ar_base-is-initialized.patch b/packages/gdb/8.0.1/0002-xtensa-make-sure-ar_base-is-initialized.patch
index 982bd7f..d056737 100644
--- a/packages/gdb/8.0.1/111-xtensa-make-sure-ar_base-is-initialized.patch
+++ b/packages/gdb/8.0.1/0002-xtensa-make-sure-ar_base-is-initialized.patch
@@ -13,14 +13,12 @@ gdb/
Signed-off-by: Max Filippov <jcmvbkbc@gmail.com>
---
- gdb/xtensa-tdep.c | 3 +++
+ gdb/xtensa-tdep.c | 3 +++
1 file changed, 3 insertions(+)
-diff --git a/gdb/xtensa-tdep.c b/gdb/xtensa-tdep.c
-index 55e7d98..41f5ec1 100644
--- a/gdb/xtensa-tdep.c
+++ b/gdb/xtensa-tdep.c
-@@ -3175,6 +3175,9 @@ xtensa_derive_tdep (struct gdbarch_tdep *tdep)
+@@ -3166,6 +3166,9 @@
tdep->num_regs = n;
}
@@ -30,6 +28,3 @@ index 55e7d98..41f5ec1 100644
/* Number of pseudo registers. */
tdep->num_pseudo_regs = n - tdep->num_regs;
---
-1.8.1.4
-
diff --git a/packages/gdb/8.0.1/112-WIP-end-of-prologue-detection-hack.patch b/packages/gdb/8.0.1/0003-WIP-end-of-prologue-detection-hack.patch
index 506a57c..f47b494 100644
--- a/packages/gdb/8.0.1/112-WIP-end-of-prologue-detection-hack.patch
+++ b/packages/gdb/8.0.1/0003-WIP-end-of-prologue-detection-hack.patch
@@ -10,14 +10,12 @@ see
Signed-off-by: Max Filippov <jcmvbkbc@gmail.com>
---
- gdb/xtensa-tdep.c | 2 +-
+ gdb/xtensa-tdep.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
-diff --git a/gdb/xtensa-tdep.c b/gdb/xtensa-tdep.c
-index 41f5ec1..6a7dba7 100644
--- a/gdb/xtensa-tdep.c
+++ b/gdb/xtensa-tdep.c
-@@ -2410,7 +2410,7 @@ call0_analyze_prologue (struct gdbarch *gdbarch,
+@@ -2410,7 +2410,7 @@
/* Find out, if we have an information about the prologue from DWARF. */
prologue_sal = find_pc_line (start, 0);
if (prologue_sal.line != 0) /* Found debug info. */
@@ -26,6 +24,3 @@ index 41f5ec1..6a7dba7 100644
/* If we are going to analyze the prologue in general without knowing about
the current PC, make the best assumtion for the end of the prologue. */
---
-1.8.1.4
-
diff --git a/packages/gdb/8.0.1/200-allow-android.patch b/packages/gdb/8.0.1/0004-allow-android.patch
index 7954477..b97871c 100644
--- a/packages/gdb/8.0.1/200-allow-android.patch
+++ b/packages/gdb/8.0.1/0004-allow-android.patch
@@ -1,7 +1,11 @@
-diff -urpN gdb-7.12.1.orig/gdb/gdbserver/configure gdb-7.12.1/gdb/gdbserver/configure
---- gdb-7.12.1.orig/gdb/gdbserver/configure 2017-05-14 17:02:46.742711695 -0700
-+++ gdb-7.12.1/gdb/gdbserver/configure 2017-05-14 17:03:22.147058607 -0700
-@@ -6671,17 +6671,6 @@ fi
+---
+ gdb/gdbserver/configure | 11 -----------
+ gdb/gdbserver/configure.ac | 11 -----------
+ 2 files changed, 22 deletions(-)
+
+--- a/gdb/gdbserver/configure
++++ b/gdb/gdbserver/configure
+@@ -7539,17 +7539,6 @@
case "${target}" in
@@ -19,10 +23,9 @@ diff -urpN gdb-7.12.1.orig/gdb/gdbserver/configure gdb-7.12.1/gdb/gdbserver/conf
*)
ac_fn_c_check_type "$LINENO" "Elf32_auxv_t" "ac_cv_type_Elf32_auxv_t" "#include <elf.h>
-diff -urpN gdb-7.12.1.orig/gdb/gdbserver/configure.ac gdb-7.12.1/gdb/gdbserver/configure.ac
---- gdb-7.12.1.orig/gdb/gdbserver/configure.ac 2017-05-14 17:02:46.742711695 -0700
-+++ gdb-7.12.1/gdb/gdbserver/configure.ac 2017-05-14 17:03:53.219361720 -0700
-@@ -179,17 +179,6 @@ AC_CHECK_TYPES(socklen_t, [], [],
+--- a/gdb/gdbserver/configure.ac
++++ b/gdb/gdbserver/configure.ac
+@@ -176,17 +176,6 @@
])
case "${target}" in