summaryrefslogtreecommitdiff
path: root/packages/glibc-ports/2.12.1/0009-do-not-use-libgcc_eh.patch
diff options
context:
space:
mode:
authorAlexey Neyman <stilor@att.net>2022-02-14 08:11:42 (GMT)
committerGitHub <noreply@github.com>2022-02-14 08:11:42 (GMT)
commit681aaef1f1ff39c341fdc529e0db2c14639a58d8 (patch)
treece98c2b3d9648db065d27add325370392a35d584 /packages/glibc-ports/2.12.1/0009-do-not-use-libgcc_eh.patch
parentba680a3e5b8c62a7c1554e71f6d09903dac95a2f (diff)
parent86c2982568de1ad4d4cc12a65b19231331484405 (diff)
Merge pull request #1674 from stilor/master
Updates to make `ct-ng build-all` pass
Diffstat (limited to 'packages/glibc-ports/2.12.1/0009-do-not-use-libgcc_eh.patch')
-rw-r--r--packages/glibc-ports/2.12.1/0009-do-not-use-libgcc_eh.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/packages/glibc-ports/2.12.1/0009-do-not-use-libgcc_eh.patch b/packages/glibc-ports/2.12.1/0009-do-not-use-libgcc_eh.patch
new file mode 100644
index 0000000..dc746c4
--- /dev/null
+++ b/packages/glibc-ports/2.12.1/0009-do-not-use-libgcc_eh.patch
@@ -0,0 +1,31 @@
+commit 95f5a9a866695da4e038aa4e6ccbbfd5d9cf63b7
+Author: Joseph Myers <joseph@codesourcery.com>
+Date: Tue Jul 3 19:14:59 2012 +0000
+
+ Avoid use of libgcc_s and libgcc_eh when building glibc.
+
+---
+ sysdeps/arm/eabi/Makefile | 8 ++++++++
+ 1 file changed, 8 insertions(+)
+
+--- a/sysdeps/arm/eabi/Makefile
++++ b/sysdeps/arm/eabi/Makefile
+@@ -1,3 +1,6 @@
++gnulib-arch = $(elfobjdir)/libgcc-stubs.a
++static-gnulib-arch = $(elfobjdir)/libgcc-stubs.a
++
+ ifeq ($(subdir),csu)
+ aeabi_constants = aeabi_lcsts aeabi_sighandlers aeabi_math
+ aeabi_routines = aeabi_assert aeabi_localeconv aeabi_errno_addr \
+@@ -24,6 +27,11 @@
+ sysdep_routines += aeabi_unwind_cpp_pr1 find_exidx
+ shared-only-routines += aeabi_unwind_cpp_pr1
+ sysdep-rtld-routines += aeabi_unwind_cpp_pr1
++
++$(objpfx)libgcc-stubs.a: $(objpfx)aeabi_unwind_cpp_pr1.os
++ $(build-extra-lib)
++
++lib-noranlib: $(objpfx)libgcc-stubs.a
+ endif
+
+ ifeq ($(subdir),math)