summaryrefslogtreecommitdiff
path: root/packages/glibc/2.18
diff options
context:
space:
mode:
authorAlexey Neyman <stilor@att.net>2017-12-02 20:44:39 (GMT)
committerAlexey Neyman <stilor@att.net>2017-12-02 20:44:39 (GMT)
commit98bc4decdeab1361bdc585c86591718fb08c8ffb (patch)
tree4e048ed57988306696efa3c5b81a80d48030e913 /packages/glibc/2.18
parent2a1935f3ad41d360dd3d96a1b0486083293651dd (diff)
Run all patches through renumbering and update
Signed-off-by: Alexey Neyman <stilor@att.net>
Diffstat (limited to 'packages/glibc/2.18')
-rw-r--r--packages/glibc/2.18/0000-4f2bcda-ARM-Fix-clone-code-when-built-for-Thumb.patch (renamed from packages/glibc/2.18/100-4f2bcda-ARM-Fix-clone-code-when-built-for-Thumb.patch)16
-rw-r--r--packages/glibc/2.18/0001-Suppress-GCC-6-warning-about-ambiguous-else-with-Wpa.patch (renamed from packages/glibc/2.18/101-Suppress-GCC-6-warning-about-ambiguous-else-with-Wpa.patch)31
-rw-r--r--packages/glibc/2.18/0002-fix-signed-shift-overlow.patch (renamed from packages/glibc/2.18/102-fix-signed-shift-overlow.patch)23
-rw-r--r--packages/glibc/2.18/0003-dl-openat64-variadic.patch (renamed from packages/glibc/2.18/103-dl-openat64-variadic.patch)6
-rw-r--r--packages/glibc/2.18/0004-unused-variables.patch (renamed from packages/glibc/2.18/104-unused-variables.patch)40
-rw-r--r--packages/glibc/2.18/0005-misleading-indentation.patch (renamed from packages/glibc/2.18/105-misleading-indentation.patch)8
-rw-r--r--packages/glibc/2.18/0006-dl-open-array-bounds.patch (renamed from packages/glibc/2.18/106-dl-open-array-bounds.patch)10
-rw-r--r--packages/glibc/2.18/0007-2770d15-Fix-PI-mutex-check-in-pthread_cond_broadcast-and-pthread_cond_signal.patch (renamed from packages/glibc/2.18/110-2770d15-Fix-PI-mutex-check-in-pthread_cond_broadcast-and-pthread_cond_signal.patch)21
-rw-r--r--packages/glibc/2.18/0008-support-make4.patch (renamed from packages/glibc/2.18/120-support-make4.patch)13
-rw-r--r--packages/glibc/2.18/0009-arm-unwind.patch (renamed from packages/glibc/2.18/130-arm-unwind.patch)27
-rw-r--r--packages/glibc/2.18/0010-Fix-combreloc-test-BSD-grep.patch (renamed from packages/glibc/2.18/140-Fix-combreloc-test-BSD-grep.patch)18
-rw-r--r--packages/glibc/2.18/0011-macos-cross-rpcgen.patch (renamed from packages/glibc/2.18/300-macos-cross-rpcgen.patch)8
-rw-r--r--packages/glibc/2.18/0012-fix-rpc_parse-format.patch (renamed from packages/glibc/2.18/920-fix-rpc_parse-format.patch)8
-rw-r--r--packages/glibc/2.18/0013-nis-bogus-conditional.patch (renamed from packages/glibc/2.18/940-nis-bogus-conditional.patch)8
14 files changed, 114 insertions, 123 deletions
diff --git a/packages/glibc/2.18/100-4f2bcda-ARM-Fix-clone-code-when-built-for-Thumb.patch b/packages/glibc/2.18/0000-4f2bcda-ARM-Fix-clone-code-when-built-for-Thumb.patch
index 40e3632..d441b0c 100644
--- a/packages/glibc/2.18/100-4f2bcda-ARM-Fix-clone-code-when-built-for-Thumb.patch
+++ b/packages/glibc/2.18/0000-4f2bcda-ARM-Fix-clone-code-when-built-for-Thumb.patch
@@ -17,11 +17,15 @@ Date: Thu Aug 29 20:10:26 2013 +0100
(cherry picked from commit 6b06ac56cdfc9293908724e51e827534e97819aa)
-diff --git a/NEWS b/NEWS
-index b023c30..f64fb82 100644
+---
+ NEWS | 6 ++++++
+ ports/ChangeLog.arm | 6 ++++++
+ ports/sysdeps/unix/sysv/linux/arm/clone.S | 4 ++--
+ 3 files changed, 14 insertions(+), 2 deletions(-)
+
--- a/NEWS
+++ b/NEWS
-@@ -5,6 +5,12 @@ See the end for copying conditions.
+@@ -5,6 +5,12 @@
Please send GNU C library bug reports via <http://sourceware.org/bugzilla/>
using `glibc' in the "product" field.
@@ -34,8 +38,6 @@ index b023c30..f64fb82 100644
Version 2.18
* The following bugs are resolved with this release:
-diff --git a/ports/ChangeLog.arm b/ports/ChangeLog.arm
-index 1e7a35c..54debd7 100644
--- a/ports/ChangeLog.arm
+++ b/ports/ChangeLog.arm
@@ -1,3 +1,9 @@
@@ -48,11 +50,9 @@ index 1e7a35c..54debd7 100644
2013-07-03 Joseph Myers <joseph@codesourcery.com>
* sysdeps/arm/include/bits/setjmp.h [_ISOMAC] (JMP_BUF_REGLIST):
-diff --git a/ports/sysdeps/unix/sysv/linux/arm/clone.S b/ports/sysdeps/unix/sysv/linux/arm/clone.S
-index ce9c2a5..6e74fa7 100644
--- a/ports/sysdeps/unix/sysv/linux/arm/clone.S
+++ b/ports/sysdeps/unix/sysv/linux/arm/clone.S
-@@ -93,8 +93,8 @@ PSEUDO_END (__clone)
+@@ -93,8 +93,8 @@
mov lr, pc
bx ip
#else
diff --git a/packages/glibc/2.18/101-Suppress-GCC-6-warning-about-ambiguous-else-with-Wpa.patch b/packages/glibc/2.18/0001-Suppress-GCC-6-warning-about-ambiguous-else-with-Wpa.patch
index 6fd663a..5d724b2 100644
--- a/packages/glibc/2.18/101-Suppress-GCC-6-warning-about-ambiguous-else-with-Wpa.patch
+++ b/packages/glibc/2.18/0001-Suppress-GCC-6-warning-about-ambiguous-else-with-Wpa.patch
@@ -5,16 +5,13 @@ Subject: [PATCH] Suppress GCC 6 warning about ambiguous 'else' with
-Wparentheses
---
- ChangeLog | 5 +++++
- nis/nis_call.c | 20 +++++++++++---------
- stdlib/setenv.c | 26 ++++++++++++++------------
- 3 files changed, 30 insertions(+), 21 deletions(-)
+ nis/nis_call.c | 20 +++++++++++---------
+ stdlib/setenv.c | 24 +++++++++++++-----------
+ 2 files changed, 24 insertions(+), 20 deletions(-)
-diff --git a/nis/nis_call.c b/nis/nis_call.c
-index 3fa37e4..cb7839a 100644
--- a/nis/nis_call.c
+++ b/nis/nis_call.c
-@@ -680,16 +680,18 @@ nis_server_cache_add (const_nis_name name, int search_parent,
+@@ -680,16 +680,18 @@
/* Choose which entry should be evicted from the cache. */
loc = &nis_server_cache[0];
if (*loc != NULL)
@@ -42,11 +39,9 @@ index 3fa37e4..cb7839a 100644
old = *loc;
*loc = new;
-diff --git a/stdlib/setenv.c b/stdlib/setenv.c
-index da61ee0..e66045f 100644
--- a/stdlib/setenv.c
+++ b/stdlib/setenv.c
-@@ -278,18 +278,20 @@ unsetenv (const char *name)
+@@ -327,18 +327,20 @@
ep = __environ;
if (ep != NULL)
while (*ep != NULL)
@@ -54,7 +49,12 @@ index da61ee0..e66045f 100644
- {
- /* Found it. Remove this pointer by moving later ones back. */
- char **dp = ep;
--
++ {
++ if (!strncmp (*ep, name, len) && (*ep)[len] == '=')
++ {
++ /* Found it. Remove this pointer by moving later ones back. */
++ char **dp = ep;
+
- do
- dp[0] = dp[1];
- while (*dp++);
@@ -62,12 +62,6 @@ index da61ee0..e66045f 100644
- }
- else
- ++ep;
-+ {
-+ if (!strncmp (*ep, name, len) && (*ep)[len] == '=')
-+ {
-+ /* Found it. Remove this pointer by moving later ones back. */
-+ char **dp = ep;
-+
+ do
+ dp[0] = dp[1];
+ while (*dp++);
@@ -79,6 +73,3 @@ index da61ee0..e66045f 100644
UNLOCK;
---
-2.7.4
-
diff --git a/packages/glibc/2.18/102-fix-signed-shift-overlow.patch b/packages/glibc/2.18/0002-fix-signed-shift-overlow.patch
index ef49f83..cf36780 100644
--- a/packages/glibc/2.18/102-fix-signed-shift-overlow.patch
+++ b/packages/glibc/2.18/0002-fix-signed-shift-overlow.patch
@@ -12,11 +12,16 @@ Date: Tue Jul 21 22:50:29 2015 -0700
* string/strchrnul.c (STRCHRNUL):
Rewrite code to avoid issues with signed shift overflow.
-diff --git a/string/memrchr.c b/string/memrchr.c
-index 0c8fd84..86cd5b9 100644
+---
+ string/memrchr.c | 11 ++---------
+ string/rawmemchr.c | 11 ++---------
+ string/strchr.c | 9 ++-------
+ string/strchrnul.c | 9 ++-------
+ 4 files changed, 8 insertions(+), 32 deletions(-)
+
--- a/string/memrchr.c
+++ b/string/memrchr.c
-@@ -96,15 +96,8 @@ MEMRCHR
+@@ -96,15 +96,8 @@
The 1-bits make sure that carries propagate to the next 0-bit.
The 0-bits provide holes for carries to fall into. */
@@ -34,11 +39,9 @@ index 0c8fd84..86cd5b9 100644
/* Set up a longword, each of whose bytes is C. */
charmask = c | (c << 8);
-diff --git a/string/rawmemchr.c b/string/rawmemchr.c
-index 05b22be..228ca9d 100644
--- a/string/rawmemchr.c
+++ b/string/rawmemchr.c
-@@ -86,15 +86,8 @@ RAWMEMCHR (s, c_in)
+@@ -83,15 +83,8 @@
The 1-bits make sure that carries propagate to the next 0-bit.
The 0-bits provide holes for carries to fall into. */
@@ -56,11 +59,9 @@ index 05b22be..228ca9d 100644
/* Set up a longword, each of whose bytes is C. */
charmask = c | (c << 8);
-diff --git a/string/strchr.c b/string/strchr.c
-index 5f90075..f13b2b3 100644
--- a/string/strchr.c
+++ b/string/strchr.c
-@@ -60,13 +60,8 @@ strchr (const char *s, int c_in)
+@@ -63,13 +63,8 @@
The 1-bits make sure that carries propagate to the next 0-bit.
The 0-bits provide holes for carries to fall into. */
@@ -76,11 +77,9 @@ index 5f90075..f13b2b3 100644
/* Set up a longword, each of whose bytes is C. */
charmask = c | (c << 8);
-diff --git a/string/strchrnul.c b/string/strchrnul.c
-index 2678f1d..daf0b3f 100644
--- a/string/strchrnul.c
+++ b/string/strchrnul.c
-@@ -66,13 +66,8 @@ STRCHRNUL (s, c_in)
+@@ -62,13 +62,8 @@
The 1-bits make sure that carries propagate to the next 0-bit.
The 0-bits provide holes for carries to fall into. */
diff --git a/packages/glibc/2.18/103-dl-openat64-variadic.patch b/packages/glibc/2.18/0003-dl-openat64-variadic.patch
index fe94b96..552db12 100644
--- a/packages/glibc/2.18/103-dl-openat64-variadic.patch
+++ b/packages/glibc/2.18/0003-dl-openat64-variadic.patch
@@ -177,8 +177,10 @@ Date: Tue Oct 20 11:54:09 2015 +0000
* wcsmbs/wcsnrtombs.c (__wcsnrtombs): Likewise.
* wcsmbs/wcsrtombs.c (__wcsrtombs): Likewise.
-diff --git a/sysdeps/unix/sysv/linux/dl-openat64.c b/sysdeps/unix/sysv/linux/dl-openat64.c
-index 7d100bb..7eea0ca 100644
+---
+ sysdeps/unix/sysv/linux/dl-openat64.c | 5 +----
+ 1 file changed, 1 insertion(+), 4 deletions(-)
+
--- a/sysdeps/unix/sysv/linux/dl-openat64.c
+++ b/sysdeps/unix/sysv/linux/dl-openat64.c
@@ -23,10 +23,7 @@
diff --git a/packages/glibc/2.18/104-unused-variables.patch b/packages/glibc/2.18/0004-unused-variables.patch
index 642edb1..0f17740 100644
--- a/packages/glibc/2.18/104-unused-variables.patch
+++ b/packages/glibc/2.18/0004-unused-variables.patch
@@ -19,8 +19,18 @@ Date: Fri Sep 18 20:27:20 2015 +0100
* timezone/private.h (time_t_min): Likewise. (time_t_max):
Likewise.
-diff --git a/resolv/base64.c b/resolv/base64.c
-index ea584ed..519e5d2 100644
+---
+ resolv/base64.c | 4 ----
+ sysdeps/ieee754/dbl-64/atnat2.h | 4 ----
+ sysdeps/ieee754/dbl-64/uexp.h | 2 +-
+ sysdeps/ieee754/dbl-64/upow.h | 2 --
+ sysdeps/ieee754/flt-32/e_log10f.c | 2 --
+ sysdeps/ieee754/flt-32/s_cosf.c | 2 --
+ sysdeps/ieee754/ldbl-128/e_lgammal_r.c | 1 -
+ sysdeps/ieee754/ldbl-128/s_erfl.c | 1 -
+ sysdeps/ieee754/ldbl-128/s_log1pl.c | 1 -
+ 9 files changed, 1 insertion(+), 18 deletions(-)
+
--- a/resolv/base64.c
+++ b/resolv/base64.c
@@ -40,10 +40,6 @@
@@ -34,8 +44,6 @@ index ea584ed..519e5d2 100644
#include <sys/types.h>
#include <sys/param.h>
#include <sys/socket.h>
-diff --git a/sysdeps/ieee754/dbl-64/atnat2.h b/sysdeps/ieee754/dbl-64/atnat2.h
-index e0d65af..82943f9 100644
--- a/sysdeps/ieee754/dbl-64/atnat2.h
+++ b/sysdeps/ieee754/dbl-64/atnat2.h
@@ -65,10 +65,8 @@
@@ -60,8 +68,6 @@ index e0d65af..82943f9 100644
/**/ mtqpi = {{0x7f3321d2, 0xc002d97c} }, /* -3pi/4 */
/**/ u1 = {{0x00000000, 0x3c314c2a} }, /* 9.377e-19 */
/**/ u2 = {{0x00000000, 0x3bf955e4} }, /* 8.584e-20 */
-diff --git a/sysdeps/ieee754/dbl-64/uexp.h b/sysdeps/ieee754/dbl-64/uexp.h
-index 6817eaf..42b21f2 100644
--- a/sysdeps/ieee754/dbl-64/uexp.h
+++ b/sysdeps/ieee754/dbl-64/uexp.h
@@ -29,7 +29,7 @@
@@ -73,8 +79,6 @@ index 6817eaf..42b21f2 100644
err_0 = 1.000014, err_1 = 0.000016;
const static int4 bigint = 0x40862002,
badint = 0x40876000,smallint = 0x3C8fffff;
-diff --git a/sysdeps/ieee754/dbl-64/upow.h b/sysdeps/ieee754/dbl-64/upow.h
-index c8569a9..b4911e5 100644
--- a/sysdeps/ieee754/dbl-64/upow.h
+++ b/sysdeps/ieee754/dbl-64/upow.h
@@ -34,7 +34,6 @@
@@ -93,11 +97,9 @@ index c8569a9..b4911e5 100644
/**/ ln2a = {{0xfefa3800, 0x3fe62e42}}, /* ln(2) 43 bits */
/**/ ln2b = {{0x93c76730, 0x3d2ef357}}, /* ln(2)-ln2a */
/**/ bigu = {{0xfffffd2c, 0x4297ffff}}, /* 1.5*2**42 -724*2**-10 */
-diff --git a/sysdeps/ieee754/flt-32/e_log10f.c b/sysdeps/ieee754/flt-32/e_log10f.c
-index 96f0e81..1daeef7 100644
--- a/sysdeps/ieee754/flt-32/e_log10f.c
+++ b/sysdeps/ieee754/flt-32/e_log10f.c
-@@ -22,8 +22,6 @@ ivln10 = 4.3429449201e-01, /* 0x3ede5bd9 */
+@@ -22,8 +22,6 @@
log10_2hi = 3.0102920532e-01, /* 0x3e9a2080 */
log10_2lo = 7.9034151668e-07; /* 0x355427db */
@@ -106,11 +108,9 @@ index 96f0e81..1daeef7 100644
float
__ieee754_log10f(float x)
{
-diff --git a/sysdeps/ieee754/flt-32/s_cosf.c b/sysdeps/ieee754/flt-32/s_cosf.c
-index 864ab27..0affd40 100644
--- a/sysdeps/ieee754/flt-32/s_cosf.c
+++ b/sysdeps/ieee754/flt-32/s_cosf.c
-@@ -21,8 +21,6 @@ static char rcsid[] = "$NetBSD: s_cosf.c,v 1.4 1995/05/10 20:47:03 jtc Exp $";
+@@ -21,8 +21,6 @@
#include <math.h>
#include <math_private.h>
@@ -119,11 +119,9 @@ index 864ab27..0affd40 100644
#ifndef COSF
# define COSF_FUNC __cosf
#else
-diff --git a/sysdeps/ieee754/ldbl-128/e_lgammal_r.c b/sysdeps/ieee754/ldbl-128/e_lgammal_r.c
-index 500aacc..ab5a96e 100644
--- a/sysdeps/ieee754/ldbl-128/e_lgammal_r.c
+++ b/sysdeps/ieee754/ldbl-128/e_lgammal_r.c
-@@ -82,7 +82,6 @@ DIAG_IGNORE_NEEDS_COMMENT (4.6, "-Woverflow");
+@@ -74,7 +74,6 @@
static const long double PIL = 3.1415926535897932384626433832795028841972E0L;
static const long double MAXLGM = 1.0485738685148938358098967157129705071571E4928L;
static const long double one = 1.0L;
@@ -131,11 +129,9 @@ index 500aacc..ab5a96e 100644
static const long double huge = 1.0e4000L;
/* log gamma(x) = ( x - 0.5 ) * log(x) - x + LS2PI + 1/x P(1/x^2)
-diff --git a/sysdeps/ieee754/ldbl-128/s_erfl.c b/sysdeps/ieee754/ldbl-128/s_erfl.c
-index fa4609f..08c80a3 100644
--- a/sysdeps/ieee754/ldbl-128/s_erfl.c
+++ b/sysdeps/ieee754/ldbl-128/s_erfl.c
-@@ -140,7 +140,6 @@ deval (long double x, const long double *p, int n)
+@@ -138,7 +138,6 @@
static const long double
tiny = 1e-4931L,
@@ -143,11 +139,9 @@ index fa4609f..08c80a3 100644
one = 1.0L,
two = 2.0L,
/* 2/sqrt(pi) - 1 */
-diff --git a/sysdeps/ieee754/ldbl-128/s_log1pl.c b/sysdeps/ieee754/ldbl-128/s_log1pl.c
-index ff759bc..9609550 100644
--- a/sysdeps/ieee754/ldbl-128/s_log1pl.c
+++ b/sysdeps/ieee754/ldbl-128/s_log1pl.c
-@@ -117,7 +117,6 @@ static const long double C2 = 1.428606820309417232121458176568075500134E-6L;
+@@ -116,7 +116,6 @@
static const long double sqrth = 0.7071067811865475244008443621048490392848L;
/* ln (2^16384 * (1 - 2^-113)) */
diff --git a/packages/glibc/2.18/105-misleading-indentation.patch b/packages/glibc/2.18/0005-misleading-indentation.patch
index 1dd8d85..8e08259 100644
--- a/packages/glibc/2.18/105-misleading-indentation.patch
+++ b/packages/glibc/2.18/0005-misleading-indentation.patch
@@ -7,11 +7,13 @@ Date: Fri Dec 11 09:19:37 2015 -0800
* sysdeps/ieee754/flt-32/k_rem_pio2f.c (__kernel_rem_pio2f):
Fix indentation.
-diff --git a/sysdeps/ieee754/flt-32/k_rem_pio2f.c b/sysdeps/ieee754/flt-32/k_rem_pio2f.c
-index 0c7685c..392afdb 100644
+---
+ sysdeps/ieee754/flt-32/k_rem_pio2f.c | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
--- a/sysdeps/ieee754/flt-32/k_rem_pio2f.c
+++ b/sysdeps/ieee754/flt-32/k_rem_pio2f.c
-@@ -65,7 +65,9 @@ int __kernel_rem_pio2f(float *x, float *y, int e0, int nx, int prec, const int32
+@@ -65,7 +65,9 @@
/* compute q[0],q[1],...q[jk] */
for (i=0;i<=jk;i++) {
diff --git a/packages/glibc/2.18/106-dl-open-array-bounds.patch b/packages/glibc/2.18/0006-dl-open-array-bounds.patch
index 08a9076..83eb0b3 100644
--- a/packages/glibc/2.18/106-dl-open-array-bounds.patch
+++ b/packages/glibc/2.18/0006-dl-open-array-bounds.patch
@@ -4,11 +4,13 @@ Date: Fri Apr 17 12:11:58 2015 -0700
Fuller check for invalid NSID in _dl_open.
-diff --git a/elf/dl-open.c b/elf/dl-open.c
-index 0dbe07f..2d0e082 100644
+---
+ elf/dl-open.c | 12 +++++++++---
+ 1 file changed, 9 insertions(+), 3 deletions(-)
+
--- a/elf/dl-open.c
+++ b/elf/dl-open.c
-@@ -211,7 +211,7 @@ dl_open_worker (void *a)
+@@ -211,7 +211,7 @@
struct link_map *l = _dl_find_dso_for_object ((ElfW(Addr)) caller_dlopen);
if (l)
@@ -17,7 +19,7 @@ index 0dbe07f..2d0e082 100644
if (args->nsid == __LM_ID_CALLER)
args->nsid = call_map->l_ns;
-@@ -619,8 +619,14 @@ no more namespaces available for dlmopen()"));
+@@ -627,8 +627,14 @@
/* Never allow loading a DSO in a namespace which is empty. Such
direct placements is only causing problems. Also don't allow
loading into a namespace used for auditing. */
diff --git a/packages/glibc/2.18/110-2770d15-Fix-PI-mutex-check-in-pthread_cond_broadcast-and-pthread_cond_signal.patch b/packages/glibc/2.18/0007-2770d15-Fix-PI-mutex-check-in-pthread_cond_broadcast-and-pthread_cond_signal.patch
index 7ad9fdf..5249bf3 100644
--- a/packages/glibc/2.18/110-2770d15-Fix-PI-mutex-check-in-pthread_cond_broadcast-and-pthread_cond_signal.patch
+++ b/packages/glibc/2.18/0007-2770d15-Fix-PI-mutex-check-in-pthread_cond_broadcast-and-pthread_cond_signal.patch
@@ -10,11 +10,16 @@ Date: Thu Oct 3 08:26:21 2013 +0530
of PTHREAD_MUTEX_ROBUST_NORMAL_NP. It has now been replaced by the
already existing convenience macro USE_REQUEUE_PI.
-diff --git a/NEWS b/NEWS
-index f64fb82..fb6069d 100644
+---
+ NEWS | 2 +-
+ nptl/ChangeLog | 9 +++++++++
+ nptl/pthread_cond_broadcast.c | 5 +----
+ nptl/pthread_cond_signal.c | 7 +------
+ 4 files changed, 12 insertions(+), 11 deletions(-)
+
--- a/NEWS
+++ b/NEWS
-@@ -9,7 +9,7 @@ Version 2.18.1
+@@ -9,7 +9,7 @@
* The following bugs are resolved with this release:
@@ -23,8 +28,6 @@ index f64fb82..fb6069d 100644
Version 2.18
-diff --git a/nptl/ChangeLog b/nptl/ChangeLog
-index eae5079..2d78490 100644
--- a/nptl/ChangeLog
+++ b/nptl/ChangeLog
@@ -1,3 +1,12 @@
@@ -40,11 +43,9 @@ index eae5079..2d78490 100644
2013-07-23 David S. Miller <davem@davemloft.net>
* tst-cancel4.c (WRITE_BUFFER_SIZE): Adjust comment.
-diff --git a/nptl/pthread_cond_broadcast.c b/nptl/pthread_cond_broadcast.c
-index 0702ec0..7ba9efa 100644
--- a/nptl/pthread_cond_broadcast.c
+++ b/nptl/pthread_cond_broadcast.c
-@@ -63,10 +63,7 @@ __pthread_cond_broadcast (cond)
+@@ -63,10 +63,7 @@
#if (defined lll_futex_cmp_requeue_pi \
&& defined __ASSUME_REQUEUE_PI)
@@ -56,11 +57,9 @@ index 0702ec0..7ba9efa 100644
{
if (lll_futex_cmp_requeue_pi (&cond->__data.__futex, 1, INT_MAX,
&mut->__data.__lock, futex_val,
-diff --git a/nptl/pthread_cond_signal.c b/nptl/pthread_cond_signal.c
-index 102d0b3..ffc35dc 100644
--- a/nptl/pthread_cond_signal.c
+++ b/nptl/pthread_cond_signal.c
-@@ -49,14 +49,9 @@ __pthread_cond_signal (cond)
+@@ -49,14 +49,9 @@
#if (defined lll_futex_cmp_requeue_pi \
&& defined __ASSUME_REQUEUE_PI)
diff --git a/packages/glibc/2.18/120-support-make4.patch b/packages/glibc/2.18/0008-support-make4.patch
index ca2bae0..a9be159 100644
--- a/packages/glibc/2.18/120-support-make4.patch
+++ b/packages/glibc/2.18/0008-support-make4.patch
@@ -10,11 +10,14 @@ X-Git-Url: https://sourceware.org/git/?p=glibc.git;a=commitdiff_plain;h=28d708c4
Accept make versions 4.0 and greater
---
-diff --git a/configure b/configure
-index f382138..5e61abd 100755
+---
+ configure | 2 +-
+ configure.in | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
--- a/configure
+++ b/configure
-@@ -4761,7 +4761,7 @@ $as_echo_n "checking version of $MAKE... " >&6; }
+@@ -4772,7 +4772,7 @@
ac_prog_version=`$MAKE --version 2>&1 | sed -n 's/^.*GNU Make[^0-9]*\([0-9][0-9.]*\).*$/\1/p'`
case $ac_prog_version in
'') ac_prog_version="v. ?.??, bad"; ac_verc_fail=yes;;
@@ -23,11 +26,9 @@ index f382138..5e61abd 100755
ac_prog_version="$ac_prog_version, ok"; ac_verc_fail=no;;
*) ac_prog_version="$ac_prog_version, bad"; ac_verc_fail=yes;;
-diff --git a/configure.in b/configure.in
-index 49b70fd..6da8efd 100644
--- a/configure.in
+++ b/configure.in
-@@ -984,7 +984,7 @@ AC_CHECK_PROG_VER(CC, ${ac_tool_prefix}gcc ${ac_tool_prefix}cc, -v,
+@@ -989,7 +989,7 @@
critic_missing="$critic_missing gcc")
AC_CHECK_PROG_VER(MAKE, gnumake gmake make, --version,
[GNU Make[^0-9]*\([0-9][0-9.]*\)],
diff --git a/packages/glibc/2.18/130-arm-unwind.patch b/packages/glibc/2.18/0009-arm-unwind.patch
index 69cc07a..85288d0 100644
--- a/packages/glibc/2.18/130-arm-unwind.patch
+++ b/packages/glibc/2.18/0009-arm-unwind.patch
@@ -1,6 +1,12 @@
-diff -urN glibc-2.18.orig/nptl/sysdeps/pthread/unwind-forcedunwind.c glibc-2.18/nptl/sysdeps/pthread/unwind-forcedunwind.c
---- glibc-2.18.orig/nptl/sysdeps/pthread/unwind-forcedunwind.c 2013-08-11 02:52:55.000000000 +0400
-+++ glibc-2.18/nptl/sysdeps/pthread/unwind-forcedunwind.c 2016-09-15 02:30:09.199939478 +0300
+---
+ nptl/sysdeps/pthread/unwind-forcedunwind.c | 2 +-
+ ports/sysdeps/unix/sysv/linux/arm/nptl/unwind-forcedunwind.c | 2 +-
+ ports/sysdeps/unix/sysv/linux/arm/nptl/unwind-resume.c | 2 +-
+ sysdeps/gnu/unwind-resume.c | 2 +-
+ 4 files changed, 4 insertions(+), 4 deletions(-)
+
+--- a/nptl/sysdeps/pthread/unwind-forcedunwind.c
++++ b/nptl/sysdeps/pthread/unwind-forcedunwind.c
@@ -24,7 +24,7 @@
#include <gnu/lib-names.h>
@@ -10,9 +16,8 @@ diff -urN glibc-2.18.orig/nptl/sysdeps/pthread/unwind-forcedunwind.c glibc-2.18/
static _Unwind_Reason_Code (*libgcc_s_personality)
(int, _Unwind_Action, _Unwind_Exception_Class, struct _Unwind_Exception *,
struct _Unwind_Context *);
-diff -urN glibc-2.18.orig/ports/sysdeps/unix/sysv/linux/arm/nptl/unwind-forcedunwind.c glibc-2.18/ports/sysdeps/unix/sysv/linux/arm/nptl/unwind-forcedunwind.c
---- glibc-2.18.orig/ports/sysdeps/unix/sysv/linux/arm/nptl/unwind-forcedunwind.c 2013-08-11 02:52:55.000000000 +0400
-+++ glibc-2.18/ports/sysdeps/unix/sysv/linux/arm/nptl/unwind-forcedunwind.c 2016-09-15 02:29:07.096945862 +0300
+--- a/ports/sysdeps/unix/sysv/linux/arm/nptl/unwind-forcedunwind.c
++++ b/ports/sysdeps/unix/sysv/linux/arm/nptl/unwind-forcedunwind.c
@@ -22,7 +22,7 @@
#include <pthreadP.h>
@@ -22,9 +27,8 @@ diff -urN glibc-2.18.orig/ports/sysdeps/unix/sysv/linux/arm/nptl/unwind-forcedun
static _Unwind_Reason_Code (*libgcc_s_personality)
(_Unwind_State, struct _Unwind_Exception *, struct _Unwind_Context *);
static _Unwind_Reason_Code (*libgcc_s_forcedunwind)
-diff -urN glibc-2.18.orig/ports/sysdeps/unix/sysv/linux/arm/nptl/unwind-resume.c glibc-2.18/ports/sysdeps/unix/sysv/linux/arm/nptl/unwind-resume.c
---- glibc-2.18.orig/ports/sysdeps/unix/sysv/linux/arm/nptl/unwind-resume.c 2013-08-11 02:52:55.000000000 +0400
-+++ glibc-2.18/ports/sysdeps/unix/sysv/linux/arm/nptl/unwind-resume.c 2016-09-15 02:29:37.352917115 +0300
+--- a/ports/sysdeps/unix/sysv/linux/arm/nptl/unwind-resume.c
++++ b/ports/sysdeps/unix/sysv/linux/arm/nptl/unwind-resume.c
@@ -20,7 +20,7 @@
#include <stdio.h>
#include <unwind.h>
@@ -34,9 +38,8 @@ diff -urN glibc-2.18.orig/ports/sysdeps/unix/sysv/linux/arm/nptl/unwind-resume.c
static _Unwind_Reason_Code (*libgcc_s_personality)
(_Unwind_State, struct _Unwind_Exception *, struct _Unwind_Context *);
-diff -urN glibc-2.18.orig/sysdeps/gnu/unwind-resume.c glibc-2.18/sysdeps/gnu/unwind-resume.c
---- glibc-2.18.orig/sysdeps/gnu/unwind-resume.c 2013-08-11 02:52:55.000000000 +0400
-+++ glibc-2.18/sysdeps/gnu/unwind-resume.c 2016-09-15 02:29:53.376431503 +0300
+--- a/sysdeps/gnu/unwind-resume.c
++++ b/sysdeps/gnu/unwind-resume.c
@@ -21,7 +21,7 @@
#include <unwind.h>
#include <gnu/lib-names.h>
diff --git a/packages/glibc/2.18/140-Fix-combreloc-test-BSD-grep.patch b/packages/glibc/2.18/0010-Fix-combreloc-test-BSD-grep.patch
index 3c34e01..e457c3c 100644
--- a/packages/glibc/2.18/140-Fix-combreloc-test-BSD-grep.patch
+++ b/packages/glibc/2.18/0010-Fix-combreloc-test-BSD-grep.patch
@@ -13,16 +13,13 @@ by configure as "not found". As a result, support for "-z combreloc"
Signed-off-by: Alexey Neyman <stilor@att.net>
---
- ChangeLog | 5 +++++
- configure | 2 +-
- configure.ac | 2 +-
- 3 files changed, 7 insertions(+), 2 deletions(-)
+ configure | 2 +-
+ configure.in | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
-diff --git a/configure b/configure
-index eecd0ac..0118bd1 100755
--- a/configure
+++ b/configure
-@@ -5804,7 +5804,7 @@ if { ac_try='${CC-cc} $CFLAGS $CPPFLAGS $LDFLAGS
+@@ -6307,7 +6307,7 @@
$as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
test $ac_status = 0; }; }
then
@@ -31,11 +28,9 @@ index eecd0ac..0118bd1 100755
libc_cv_z_combreloc=yes
else
libc_cv_z_combreloc=no
-diff --git a/configure.ac b/configure.ac
-index 4a77411..19f6d87 100644
--- a/configure.in
+++ b/configure.in
-@@ -1391,7 +1391,7 @@ dnl cross-platform since the gcc used can be a cross compiler. Without
+@@ -1596,7 +1596,7 @@
dnl introducing new options this is not easily doable. Instead use a tool
dnl which always is cross-platform: readelf. To detect whether -z combreloc
dnl look for a section named .rel.dyn.
@@ -44,6 +39,3 @@ index 4a77411..19f6d87 100644
libc_cv_z_combreloc=yes
else
libc_cv_z_combreloc=no
---
-2.9.3
-
diff --git a/packages/glibc/2.18/300-macos-cross-rpcgen.patch b/packages/glibc/2.18/0011-macos-cross-rpcgen.patch
index e654644..b439b0f 100644
--- a/packages/glibc/2.18/300-macos-cross-rpcgen.patch
+++ b/packages/glibc/2.18/0011-macos-cross-rpcgen.patch
@@ -14,11 +14,13 @@ Date: Sat Sep 7 00:01:08 2013 +0800
Signed-off-by: Jia Liu <proljc@gmail.com>
Signed-off-by: Mike Frysinger <vapier@gentoo.org>
-diff --git a/sunrpc/rpc/types.h b/sunrpc/rpc/types.h
-index 3dca5c4..beded52 100644
+---
+ sunrpc/rpc/types.h | 5 +++++
+ 1 file changed, 5 insertions(+)
+
--- a/sunrpc/rpc/types.h
+++ b/sunrpc/rpc/types.h
-@@ -69,6 +69,11 @@ typedef unsigned long rpcport_t;
+@@ -69,6 +69,11 @@
#include <sys/types.h>
#endif
diff --git a/packages/glibc/2.18/920-fix-rpc_parse-format.patch b/packages/glibc/2.18/0012-fix-rpc_parse-format.patch
index 37e58da..341d541 100644
--- a/packages/glibc/2.18/920-fix-rpc_parse-format.patch
+++ b/packages/glibc/2.18/0012-fix-rpc_parse-format.patch
@@ -45,11 +45,13 @@ Date: Tue Nov 8 23:44:51 2016 +0000
[$(run-built-tests) = yes] (tests-special): Add $(rpcgen-tests).
[$(run-built-tests) = yes] ($(rpcgen-tests)): New rule.
-diff --git a/sunrpc/rpc_parse.c b/sunrpc/rpc_parse.c
-index 1a1df6d8c2..505a6554cf 100644
+---
+ sunrpc/rpc_parse.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
--- a/sunrpc/rpc_parse.c
+++ b/sunrpc/rpc_parse.c
-@@ -521,7 +521,7 @@ static void
+@@ -521,7 +521,7 @@
get_prog_declaration (declaration * dec, defkind dkind, int num /* arg number */ )
{
token tok;
diff --git a/packages/glibc/2.18/940-nis-bogus-conditional.patch b/packages/glibc/2.18/0013-nis-bogus-conditional.patch
index 09b38cf..e728368 100644
--- a/packages/glibc/2.18/940-nis-bogus-conditional.patch
+++ b/packages/glibc/2.18/0013-nis-bogus-conditional.patch
@@ -47,11 +47,13 @@ Date: Wed Dec 21 23:44:01 2016 +0000
* nis/nss_nisplus/nisplus-alias.c (_nss_nisplus_getaliasbyname_r):
Compare name == NULL, not name != NULL.
-diff --git a/nis/nss_nisplus/nisplus-alias.c b/nis/nss_nisplus/nisplus-alias.c
-index 7f698b4e6d..cb5acce01d 100644
+---
+ nis/nss_nisplus/nisplus-alias.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
--- a/nis/nss_nisplus/nisplus-alias.c
+++ b/nis/nss_nisplus/nisplus-alias.c
-@@ -291,7 +291,7 @@ _nss_nisplus_getaliasbyname_r (const char *name, struct aliasent *alias,
+@@ -291,7 +291,7 @@
return status;
}