summaryrefslogtreecommitdiff
path: root/packages/ltrace/0.7.3
diff options
context:
space:
mode:
authorAlexey Neyman <stilor@att.net>2017-05-20 04:58:46 (GMT)
committerAlexey Neyman <stilor@att.net>2017-07-08 17:57:56 (GMT)
commite7deac3aad394325f9e6fc6fda41d34ec94a59e0 (patch)
tree6ad88362f0bfa8385a91eb494009a4646aeb74b6 /packages/ltrace/0.7.3
parentb9af225f58e45c7fae7eb9d3689fe939243e7578 (diff)
Switch comp.libs/tools and debug to new framework.
Signed-off-by: Alexey Neyman <stilor@att.net>
Diffstat (limited to 'packages/ltrace/0.7.3')
-rw-r--r--packages/ltrace/0.7.3/001-avoid-libstdc++.patch43
-rw-r--r--packages/ltrace/0.7.3/002-printf-p.patch18
-rw-r--r--packages/ltrace/0.7.3/003-alpha-debug.h.patch17
-rw-r--r--packages/ltrace/0.7.3/004-compile-warning.patch28
-rw-r--r--packages/ltrace/0.7.3/005-sparc-ftbfs.patch31
-rw-r--r--packages/ltrace/0.7.3/006-unexpected-breakpoint.patch22
-rw-r--r--packages/ltrace/0.7.3/007-gcc-5.patch25
-rw-r--r--packages/ltrace/0.7.3/008-glibc-2.24.patch28
-rw-r--r--packages/ltrace/0.7.3/version.desc0
9 files changed, 212 insertions, 0 deletions
diff --git a/packages/ltrace/0.7.3/001-avoid-libstdc++.patch b/packages/ltrace/0.7.3/001-avoid-libstdc++.patch
new file mode 100644
index 0000000..9cbf557
--- /dev/null
+++ b/packages/ltrace/0.7.3/001-avoid-libstdc++.patch
@@ -0,0 +1,43 @@
+From: Juan Cespedes <cespedes@debian.org>
+Description: avoid warning from dpkg-shlibdeps:
+ package could avoid a useless dependency if ltrace was not
+ linked against libstdc++.so.6 (it uses none of the library's symbols)
+Last-Update: 2013-12-30
+
+
+--- a/configure.ac 2013-09-17 01:04:28.000000000 +0200
++++ b/configure.ac 2013-12-30 12:24:20.000000000 +0100
+@@ -113,6 +113,15 @@
+ libstdcxx_LIBS=""])
+ AC_SUBST(libstdcxx_LIBS)
+
++if test "x$liberty_LIBS" != "x"
++then
++ libsupcxx_LIBS=""
++ libstdcxx_LIBS=""
++elif test "x$libsupcxx_LIBS" != "x"
++then
++ libstdcxx_LIBS=""
++fi
++
+
+ dnl Check security_get_boolean_active availability.
+ AC_CHECK_HEADERS(selinux/selinux.h)
+--- a/configure 2013-09-17 01:07:46.000000000 +0100
++++ b/configure 2013-12-30 12:34:23.000000000 +0100
+@@ -11826,6 +11826,15 @@
+
+
+
++if test "x$liberty_LIBS" != "x"
++then
++ libsupcxx_LIBS=""
++ libstdcxx_LIBS=""
++elif test "x$libsupcxx_LIBS" != "x"
++then
++ libstdcxx_LIBS=""
++fi
++
+
+ for ac_header in selinux/selinux.h
+ do :
diff --git a/packages/ltrace/0.7.3/002-printf-p.patch b/packages/ltrace/0.7.3/002-printf-p.patch
new file mode 100644
index 0000000..10631d9
--- /dev/null
+++ b/packages/ltrace/0.7.3/002-printf-p.patch
@@ -0,0 +1,18 @@
+From: Juan Cespedes <cespedes@debian.org>
+Description: Prevent freeing static-alloc'd memory for %p and %n in printf
+Bug-Debian: http://bugs.debian.org/614994
+Forwarded: http://lists.alioth.debian.org/pipermail/ltrace-devel/2013-September/000953.html
+Last-Update: 2014-01-02
+
+
+--- ltrace-0.7.3.orig/printf.c
++++ ltrace-0.7.3/printf.c
+@@ -168,7 +168,7 @@ form_next_param(struct param_enum *self,
+ type_init_pointer(infop, array, 1);
+
+ } else if (format_type == ARGTYPE_POINTER) {
+- type_init_pointer(infop, elt_info, 1);
++ type_init_pointer(infop, elt_info, 0);
+
+ } else {
+ *infop = *type_get_simple(format_type);
diff --git a/packages/ltrace/0.7.3/003-alpha-debug.h.patch b/packages/ltrace/0.7.3/003-alpha-debug.h.patch
new file mode 100644
index 0000000..237026d
--- /dev/null
+++ b/packages/ltrace/0.7.3/003-alpha-debug.h.patch
@@ -0,0 +1,17 @@
+From: Juan Cespedes <cespedes@debian.org>
+Description: fixed FTBFS on alpha
+ don't include "debug.h" twice
+Last-Update: 2014-01-02
+Bug-Debian: http://bugs.debian.org/678721
+
+
+--- ltrace-0.7.3.orig/sysdeps/linux-gnu/alpha/trace.c
++++ ltrace-0.7.3/sysdeps/linux-gnu/alpha/trace.c
+@@ -29,7 +29,6 @@
+
+ #include "proc.h"
+ #include "common.h"
+-#include "debug.h"
+
+ #if (!defined(PTRACE_PEEKUSER) && defined(PTRACE_PEEKUSR))
+ # define PTRACE_PEEKUSER PTRACE_PEEKUSR
diff --git a/packages/ltrace/0.7.3/004-compile-warning.patch b/packages/ltrace/0.7.3/004-compile-warning.patch
new file mode 100644
index 0000000..ad65829
--- /dev/null
+++ b/packages/ltrace/0.7.3/004-compile-warning.patch
@@ -0,0 +1,28 @@
+From: Juan Cespedes <cespedes@debian.org>
+Description: Fix compile warning
+Last-Update: 2014-01-02
+Forwarded: not-needed
+
+
+--- ltrace-0.7.3.orig/value.c
++++ ltrace-0.7.3/value.c
+@@ -284,7 +284,7 @@ value_init_deref(struct value *ret_val,
+
+ /* We need "long" to be long enough to hold platform
+ * pointers. */
+- typedef char assert__long_enough_long[-(sizeof(l) < sizeof(void *))];
++ (void)sizeof(char[1 - 2*(sizeof(l) < sizeof(void *))]);
+
+ value_common_init(ret_val, valp->inferior, valp,
+ valp->type->u.ptr_info.info, 0);
+--- ltrace-0.7.3.orig/lens_default.c
++++ ltrace-0.7.3/lens_default.c
+@@ -344,7 +344,7 @@ format_array(FILE *stream, struct value
+ {
+ /* We need "long" to be long enough to cover the whole address
+ * space. */
+- typedef char assert__long_enough_long[-(sizeof(long) < sizeof(void *))];
++ (void)sizeof(char[1 - 2*(sizeof(long) < sizeof(void *))]);
+ long l;
+ if (expr_eval_word(length, value, arguments, &l) < 0)
+ return -1;
diff --git a/packages/ltrace/0.7.3/005-sparc-ftbfs.patch b/packages/ltrace/0.7.3/005-sparc-ftbfs.patch
new file mode 100644
index 0000000..266a8e6
--- /dev/null
+++ b/packages/ltrace/0.7.3/005-sparc-ftbfs.patch
@@ -0,0 +1,31 @@
+From: Juan Cespedes <cespedes@debian.org>
+Description: fixes compilation on sparc
+Last-Update: 2014-01-02
+
+
+--- ltrace-0.7.3.orig/sysdeps/linux-gnu/sparc/plt.c
++++ ltrace-0.7.3/sysdeps/linux-gnu/sparc/plt.c
+@@ -19,8 +19,9 @@
+ */
+
+ #include <gelf.h>
++
+ #include "proc.h"
+-#include "common.h"
++#include "library.h"
+
+ GElf_Addr
+ arch_plt_sym_val(struct ltelf *lte, size_t ndx, GElf_Rela * rela) {
+--- ltrace-0.7.3.orig/sysdeps/linux-gnu/sparc/trace.c
++++ ltrace-0.7.3/sysdeps/linux-gnu/sparc/trace.c
+@@ -26,8 +26,10 @@
+ #include <sys/wait.h>
+ #include <signal.h>
+ #include <string.h>
++
+ #include "ptrace.h"
+ #include "proc.h"
++#include "backend.h"
+ #include "common.h"
+
+ void
diff --git a/packages/ltrace/0.7.3/006-unexpected-breakpoint.patch b/packages/ltrace/0.7.3/006-unexpected-breakpoint.patch
new file mode 100644
index 0000000..443bee4
--- /dev/null
+++ b/packages/ltrace/0.7.3/006-unexpected-breakpoint.patch
@@ -0,0 +1,22 @@
+From: Juan Cespedes <cespedes@debian.org>
+Description: continue after unexpected breakpoint
+ (instead of decrementing PC and execute int3 again and again)
+Last-Update: 2014-01-03
+
+
+--- ltrace-0.7.3.orig/handle_event.c
++++ ltrace-0.7.3/handle_event.c
+@@ -656,9 +656,12 @@ handle_breakpoint(Event *event)
+
+ if ((sbp = address2bpstruct(leader, brk_addr)) != NULL)
+ breakpoint_on_hit(sbp, event->proc);
+- else if (event->proc->state != STATE_IGNORED)
++ else if (event->proc->state != STATE_IGNORED) {
+ output_line(event->proc,
+ "unexpected breakpoint at %p", brk_addr);
++ continue_process(event->proc->pid);
++ return;
++ }
+
+ /* breakpoint_on_hit may delete its own breakpoint, so we have
+ * to look it up again. */
diff --git a/packages/ltrace/0.7.3/007-gcc-5.patch b/packages/ltrace/0.7.3/007-gcc-5.patch
new file mode 100644
index 0000000..4c62f85
--- /dev/null
+++ b/packages/ltrace/0.7.3/007-gcc-5.patch
@@ -0,0 +1,25 @@
+From 8c3674c86688a79a8689772c3d0c84d6e7aaa118 Mon Sep 17 00:00:00 2001
+From: Petr Machata <pmachata@redhat.com>
+Date: Tue, 8 Jan 2013 23:22:49 +0100
+Subject: Fix conditions in elf_read_u{16,32,64}
+
+- The calling convention of need_data is 0 on success, <0 on failure.
+ The condition seems to have it all mixed, using both a ! and a
+ comparison.
+
+diff --git a/ltrace-elf.c b/ltrace-elf.c
+index 29c204f..0ecdc38 100644
+--- a/ltrace-elf.c
++++ b/ltrace-elf.c
+@@ -219,7 +219,7 @@ need_data(Elf_Data *data, GElf_Xword offset, GElf_Xword size)
+ int \
+ NAME(Elf_Data *data, GElf_Xword offset, uint##SIZE##_t *retp) \
+ { \
+- if (!need_data(data, offset, SIZE / 8) < 0) \
++ if (need_data(data, offset, SIZE / 8) < 0) \
+ return -1; \
+ \
+ if (data->d_buf == NULL) /* NODATA section */ { \
+--
+cgit v0.10.2
+
diff --git a/packages/ltrace/0.7.3/008-glibc-2.24.patch b/packages/ltrace/0.7.3/008-glibc-2.24.patch
new file mode 100644
index 0000000..85b008b
--- /dev/null
+++ b/packages/ltrace/0.7.3/008-glibc-2.24.patch
@@ -0,0 +1,28 @@
+diff -urpN ltrace-0.7.3.orig/sysdeps/linux-gnu/proc.c ltrace-0.7.3/sysdeps/linux-gnu/proc.c
+--- ltrace-0.7.3.orig/sysdeps/linux-gnu/proc.c 2013-01-02 06:24:46.000000000 -0800
++++ ltrace-0.7.3/sysdeps/linux-gnu/proc.c 2016-11-13 11:24:32.760365875 -0800
+@@ -240,14 +240,18 @@ process_tasks(pid_t pid, pid_t **ret_tas
+ size_t alloc = 0;
+
+ while (1) {
+- struct dirent entry;
+ struct dirent *result;
+- if (readdir_r(d, &entry, &result) != 0) {
+- free(tasks);
+- return -1;
+- }
+- if (result == NULL)
++
++ errno = 0;
++ result = readdir(d);
++ if (result == NULL) {
++ if (errno) {
++ free(tasks);
++ closedir(d);
++ return -1;
++ }
+ break;
++ }
+ if (result->d_type == DT_DIR && all_digits(result->d_name)) {
+ pid_t npid = atoi(result->d_name);
+ if (n >= alloc) {
diff --git a/packages/ltrace/0.7.3/version.desc b/packages/ltrace/0.7.3/version.desc
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/packages/ltrace/0.7.3/version.desc