summaryrefslogtreecommitdiff
path: root/packages/zlib/1.2.11/120-mingw-static-only.patch
diff options
context:
space:
mode:
authorAlexey Neyman <stilor@att.net>2017-07-13 07:38:03 (GMT)
committerGitHub <noreply@github.com>2017-07-13 07:38:03 (GMT)
commit45c5bb0f484cba724be2c6105801dcce9a1a82d9 (patch)
tree8fd1c8eaa2ef203009d72b6ca6348611dcc5ee1c /packages/zlib/1.2.11/120-mingw-static-only.patch
parent8f8e131d566af1f577d8fb6e62e6f121b7955472 (diff)
parentb32fcf7c1eea890a2bd3f88487f818ba241aabb1 (diff)
Merge pull request #767 from stilor/packages
Packages
Diffstat (limited to 'packages/zlib/1.2.11/120-mingw-static-only.patch')
-rw-r--r--packages/zlib/1.2.11/120-mingw-static-only.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/packages/zlib/1.2.11/120-mingw-static-only.patch b/packages/zlib/1.2.11/120-mingw-static-only.patch
new file mode 100644
index 0000000..9eef00b
--- /dev/null
+++ b/packages/zlib/1.2.11/120-mingw-static-only.patch
@@ -0,0 +1,25 @@
+diff -urpN zlib-1.2.11.orig/win32/Makefile.gcc zlib-1.2.11/win32/Makefile.gcc
+--- zlib-1.2.11.orig/win32/Makefile.gcc 2017-05-23 18:52:07.937730080 -0700
++++ zlib-1.2.11/win32/Makefile.gcc 2017-05-23 19:02:24.068666463 -0700
+@@ -71,7 +71,11 @@ OBJS = adler32.o compress.o crc32.o defl
+ gzwrite.o infback.o inffast.o inflate.o inftrees.o trees.o uncompr.o zutil.o
+ OBJA =
+
+-all: $(STATICLIB) $(SHAREDLIB) $(IMPLIB) example.exe minigzip.exe example_d.exe minigzip_d.exe
++all: $(STATICLIB) example.exe minigzip.exe
++
++ifeq ($(SHARED_MODE),1)
++all: $(SHAREDLIB) $(IMPLIB) example_d.exe minigzip_d.exe
++endif
+
+ test: example.exe minigzip.exe
+ ./example
+@@ -125,7 +129,7 @@ zlibrc.o: win32/zlib1.rc
+ .PHONY: install uninstall clean
+
+ install: zlib.h zconf.h $(STATICLIB) $(IMPLIB)
+- @if test -z "$(DESTDIR)$(INCLUDE_PATH)" -o -z "$(DESTDIR)$(LIBRARY_PATH)" -o -z "$(DESTDIR)$(BINARY_PATH)"; then \
++ @if test -z "$(INCLUDE_PATH)" -o -z "$(LIBRARY_PATH)" -o -z "$(BINARY_PATH)"; then \
+ echo INCLUDE_PATH, LIBRARY_PATH, and BINARY_PATH must be specified; \
+ exit 1; \
+ fi