summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am31
1 files changed, 26 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 5ee3682..92b8af5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -7,7 +7,8 @@ SUBDIRS = kconfig
bin_SCRIPTS = ct-ng
CLEANFILES = ct-ng bash-completion/ct-ng docs/ct-ng.1
-EXTRA_DIST = bootstrap ct-ng.in bash-completion/ct-ng.in docs/ct-ng.1.in maintainer
+EXTRA_DIST = bootstrap ct-ng.in bash-completion/ct-ng.in \
+ docs/ct-ng.1.in packages maintainer
if INSTALL_BASH_COMPLETION
compdir = @BASH_COMPLETION_DIR@
@@ -64,14 +65,34 @@ bash-completion/ct-ng: bash-completion/ct-ng.in Makefile
install-data-hook:
rm -f $(DESTDIR)$(man1dir)/$(ctng_progname).1.gz
gzip -9 $(DESTDIR)$(man1dir)/$(ctng_progname).1
- chmod +x $(DESTDIR)$(pkgdatadir)/scripts/config.guess
- chmod +x $(DESTDIR)$(pkgdatadir)/scripts/config.sub
+ chmod a+x $(DESTDIR)$(pkgdatadir)/scripts/config.guess
+ chmod a+x $(DESTDIR)$(pkgdatadir)/scripts/config.sub
if INSTALL_BASH_COMPLETION
- chmod -x $(DESTDIR)$(compdir)/$(ctng_progname)
+ chmod a-x $(DESTDIR)$(compdir)/$(ctng_progname)
endif
uninstall-hook:
rm -f $(DESTDIR)$(man1dir)/$(ctng_progname).1.gz
-dist-hook: maintainer/download-docs.sh
+dist-hook: fetch-docs gen-tarball-version
+
+.PHONY: fetch-docs
+fetch-docs: maintainer/download-docs.sh
$< $(top_distdir) $(USER_MANUAL_FILES)
+
+.PHONY: gen-tarball-version
+gen-tarball-version:
+ echo $(VERSION) > $(distdir)/.tarball-version
+
+DIGESTS = md5 sha1 sha512
+USE_GPG = yes
+
+dist-create-release: distcheck
+ for a in $(DIST_ARCHIVES); do \
+ for d in $(DIGESTS); do \
+ $${d}sum $${a} > $${a}.$${d}; \
+ done; \
+ if [ "$(USE_GPG)" = "yes" ]; then \
+ gpg --detach-sign $${a}; \
+ fi; \
+ done