summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a8a615b..ce26b1c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -220,6 +220,20 @@ AC_CACHE_CHECK([for GNU make >= 3.80], [ac_cv_path_MAKE],
AC_SUBST([MAKE], [$ac_cv_path_MAKE])
AC_PROG_MAKE_SET
+# Check for GNU make 3.81 exactly, otherwise
+# it will be built as a companion tool.
+AC_MSG_CHECKING([for make 3.81])
+AS_IF(
+ [test "$MAKE_ver" = "GNU Make 3.81"],
+ [make381="y"
+ AC_MSG_RESULT([yes])
+ ],
+ [make381=
+ AC_MSG_RESULT([no])
+ ]
+ )
+ACX_SET_KCONFIG_OPTION([make381])
+
#----------------------------------------
# Check for libtool >= 1.5.26
AC_CACHE_VAL([ac_cv_path_LIBTOOL],