summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac44
1 files changed, 13 insertions, 31 deletions
diff --git a/configure.ac b/configure.ac
index 439cdca..60ba535 100644
--- a/configure.ac
+++ b/configure.ac
@@ -162,36 +162,18 @@ AC_ARG_VAR([INSTALL], [Specify the full path to a BSD-compatible install])
AC_PROG_INSTALL
ACX_WITH_DEPRECATED([grep], [GREP])
-AC_ARG_VAR([INSTALL], [Specify the full path to GNU grep])
+AC_ARG_VAR([GREP], [Specify the full path to GNU grep])
AC_PROG_GREP
AC_PROG_EGREP
AS_IF([test "$EGREP" != "$GREP -E"],
[AC_MSG_ERROR([egrep is not $GREP -E])])
-ACX_WITH_DEPRECATED([sed], [SED])
-AC_ARG_VAR([INSTALL], [Specify the full path to GNU sed])
-AC_PROG_SED
-AC_CACHE_CHECK([whether $SED understands -i -e],
- [acx_cv_sed_i_e],
- [echo foo > .ct-ng.sed.test
- ${SED} -i -e 's/foo/bar/' .ct-ng.sed.test >/dev/null 2>&1
- rc=$?
- content=`cat .ct-ng.sed.test`
- rm -f .ct-ng.sed.test
- AS_IF([test "$rc:$content" = "0:bar"],
- [acx_cv_sed_i_e=yes],
- [AC_MSG_ERROR([sed does not accept -i -e])])])
-AC_CACHE_CHECK([which $SED option selects extended regexp],
- [acx_cv_sed_r],
- [opt_r=`echo foo | $SED -r -e 's/f(o)o/b\1ar/' 2>/dev/null`
- opt_E=`echo foo | $SED -E -e 's/f(o)o/b\1ar/' 2>/dev/null`
- AS_IF([test "$opt_r" = "boar"],
- [acx_cv_sed_r=-r],
- [test "$opt_E" = "boar"],
- [acx_cv_sed_r=-E],
- [AC_MSG_ERROR([neither -r nor -E enables extended regexp])])])
-SED_R="$SED $acx_cv_sed_r"
-AC_SUBST([SED_R])
+ACX_PROG_VERSION_REQ_STRICT([SED],
+ [GNU sed >= 4.0],
+ [sed],
+ [gsed sed],
+ ['GNU sed[^0-9]* [4-9]\.'])
+AC_ARG_VAR([SED], [Specify the full path to GNU sed])
AC_PROG_LN_S
@@ -306,42 +288,42 @@ ACX_PROG_VERSION([LIBTOOL],
[GNU libtool >= 2.4],
[libtool],
[glibtool libtool],
- ['^libtool \(GNU libtool\) ([3-9]\.|2.[4-9]|2.[1-3][0-9])'],
+ ['\(GNU libtool\) ([3-9]\.|2.[4-9]|2.[1-3][0-9])'],
[libtool_2_4_or_newer])
ACX_PROG_VERSION([LIBTOOLIZE],
[GNU libtoolize >= 2.4],
[libtoolize],
[glibtoolize libtoolize],
- ['^libtoolize \(GNU libtool\) ([3-9]\.|2.[4-9]|2.[1-3][0-9])'],
+ ['\(GNU libtool\) ([3-9]\.|2.[4-9]|2.[1-3][0-9])'],
[libtoolize_2_4_or_newer])
ACX_PROG_VERSION([AUTOCONF],
[GNU autoconf >= 2.65],
[AUTOCONF],
[autoconf],
- ['^autoconf \(GNU Autoconf\) ([3-9]\.|2\.[7-9][0-9]|2\.6[5-9])'],
+ ['\(GNU Autoconf\) ([3-9]\.|2\.[7-9][0-9]|2\.6[5-9])'],
[autoconf_2_63_or_newer])
ACX_PROG_VERSION([AUTORECONF],
[GNU autoreconf >= 2.63],
[autoreconf],
[autoreconf],
- ['^autoreconf \(GNU Autoconf\) ([3-9]\.|2\.[7-9][0-9]|2\.6[3-9])'],
+ ['\(GNU Autoconf\) ([3-9]\.|2\.[7-9][0-9]|2\.6[3-9])'],
[autoreconf_2_63_or_newer])
ACX_PROG_VERSION([AUTOMAKE],
[GNU automake >= 1.15],
[automake],
[automake],
- ['automake \(GNU automake\) ([2-9]\.|1\.[2-9][0-9]|1\.1[5-9])'],
+ ['\(GNU automake\) ([2-9]\.|1\.[2-9][0-9]|1\.1[5-9])'],
[automake_1_15_or_newer])
ACX_PROG_VERSION([M4],
[GNU m4 >= 1.4.12],
[m4],
[gm4 m4],
- ['^m4 \(GNU M4\) ([2-9]\.|1\.[5-9]|1\.[1-4][0-9]|1\.4\.[2-9][0-9]|1\.4\.1[2-9])'],
+ ['\(GNU M4\) ([2-9]\.|1\.[5-9]|1\.[1-4][0-9]|1\.4\.[2-9][0-9]|1\.4\.1[2-9])'],
[gnu_m4_1_4_12_or_newer])
#----------------------------------------