summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rwxr-xr-x[-rw-r--r--]configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index a4a9cb9..b922482 100644..100755
--- a/configure.ac
+++ b/configure.ac
@@ -321,7 +321,7 @@ AC_FUNC_REALLOC
AC_FUNC_ALLOCA
#----------------------------------------
-# Check for gettext, for the kconfig frontends
+# Check for gettext and libintl for the kconfig frontends
AC_SUBST([gettext])
AC_CHECK_HEADERS(
[libintl.h],
@@ -333,6 +333,10 @@ AS_IF(
[gettext=y],,
[AC_INCLUDES_DEFAULT()
#include <$ac_ct_gettext_hdr>])])
+SAVE_LIBS=$LIBS
+AC_SEARCH_LIBS(bindtextdomain, intl, [test "$ac_res" = "none required" || INTL_LIBS="${ac_res}"])
+LIBS=$SAVE_LIBS
+AC_SUBST([INTL_LIBS])
#----------------------------------------
# Check for ncurses, for the kconfig frontends