summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index adde2ab..5670a03 100644
--- a/configure.ac
+++ b/configure.ac
@@ -67,6 +67,16 @@ AC_ARG_ENABLE(
[do not install, and use current directory])])
AC_SUBST([enable_local], [${enable_local:-no}])
AC_ARG_ENABLE(
+ [automated],
+ [AS_HELP_STRING(
+ [--enable-automated],
+ [Tell ct-ng that this is an automated build])],
+ [if test "x$automated" = "x" -o "x$automated" = "xyes"; then
+ automated=y
+ fi])
+AC_SUBST([enable_automated], [${enable_automated:-no}])
+ACX_SET_KCONFIG_OPTION([automated])
+AC_ARG_ENABLE(
[shared],
[AS_HELP_STRING(
[--enable-shared],