summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 3 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index f5c5e10..4f0b428 100644
--- a/configure.ac
+++ b/configure.ac
@@ -339,15 +339,6 @@ LIBS=$SAVE_LIBS
AC_SUBST([INTL_LIBS])
#----------------------------------------
-# Check for tinfo, for the kconfig frontends
-AC_SEARCH_LIBS(
- [tigetnum],
- [tinfo],
- [ac_ct_tinfo_lib_found=yes; break])
-AS_IF(
- [test -z "$ac_ct_tinfo_lib_found"],
- [AC_MSG_ERROR([could not find tinfo library, required for the kconfig frontends])])
-
# Check for ncurses, for the kconfig frontends
AC_SUBST([ac_ct_curses_hdr])
AC_CHECK_HEADERS(
@@ -363,6 +354,9 @@ AC_SEARCH_LIBS(
AS_IF(
[test -z "$ac_ct_curses_lib_found"],
[AC_MSG_ERROR([could not find curses library, required for the kconfig frontends])])
+AC_SEARCH_LIBS(
+ [tgetent],
+ [termcap tinfo ncursesw ncurses curses])
#--------------------------------------------------------------------
# Lastly, take care of crosstool-NG internal values