summaryrefslogtreecommitdiff
path: root/packages/gdb/8.2.1/0004-allow-android.patch
diff options
context:
space:
mode:
Diffstat (limited to 'packages/gdb/8.2.1/0004-allow-android.patch')
-rw-r--r--packages/gdb/8.2.1/0004-allow-android.patch45
1 files changed, 45 insertions, 0 deletions
diff --git a/packages/gdb/8.2.1/0004-allow-android.patch b/packages/gdb/8.2.1/0004-allow-android.patch
new file mode 100644
index 0000000..c14d3df
--- /dev/null
+++ b/packages/gdb/8.2.1/0004-allow-android.patch
@@ -0,0 +1,45 @@
+---
+ gdb/gdbserver/configure | 11 -----------
+ gdb/gdbserver/configure.ac | 11 -----------
+ 2 files changed, 22 deletions(-)
+
+--- a/gdb/gdbserver/configure
++++ b/gdb/gdbserver/configure
+@@ -7645,17 +7645,6 @@
+
+
+ case "${target}" in
+- *-android*)
+- # Starting with NDK version 9, <elf.h> actually includes definitions
+- # of Elf32_auxv_t and Elf64_auxv_t. But sadly, <elf.h> includes
+- # <sys/exec_elf.h> which defines some of the ELF types incorrectly,
+- # leading to conflicts with the defintions from <linux/elf.h>.
+- # This makes it impossible for us to include both <elf.h> and
+- # <linux/elf.h>, which means that, in practice, we do not have
+- # access to Elf32_auxv_t and Elf64_auxv_t on this platform.
+- # Therefore, do not try to auto-detect availability, as it would
+- # get it wrong on this platform.
+- ;;
+ *)
+ ac_fn_c_check_type "$LINENO" "Elf32_auxv_t" "ac_cv_type_Elf32_auxv_t" "#include <elf.h>
+
+--- a/gdb/gdbserver/configure.ac
++++ b/gdb/gdbserver/configure.ac
+@@ -193,17 +193,6 @@
+ ])
+
+ case "${target}" in
+- *-android*)
+- # Starting with NDK version 9, <elf.h> actually includes definitions
+- # of Elf32_auxv_t and Elf64_auxv_t. But sadly, <elf.h> includes
+- # <sys/exec_elf.h> which defines some of the ELF types incorrectly,
+- # leading to conflicts with the defintions from <linux/elf.h>.
+- # This makes it impossible for us to include both <elf.h> and
+- # <linux/elf.h>, which means that, in practice, we do not have
+- # access to Elf32_auxv_t and Elf64_auxv_t on this platform.
+- # Therefore, do not try to auto-detect availability, as it would
+- # get it wrong on this platform.
+- ;;
+ *)
+ AC_CHECK_TYPES([Elf32_auxv_t, Elf64_auxv_t], [], [],
+ #include <elf.h>