summaryrefslogtreecommitdiff
path: root/packages/ltrace/0.5.3
diff options
context:
space:
mode:
Diffstat (limited to 'packages/ltrace/0.5.3')
-rw-r--r--packages/ltrace/0.5.3/0000-allow-cross-compile.patch (renamed from packages/ltrace/0.5.3/100-allow-cross-compile.patch)36
-rw-r--r--packages/ltrace/0.5.3/0001-alpha-support.patch14
-rw-r--r--packages/ltrace/0.5.3/0002-debian-ltrace_0.5.3-2.patch (renamed from packages/ltrace/0.5.3/120-debian-ltrace_0.5.3-2.patch)28
-rw-r--r--packages/ltrace/0.5.3/0003-add-sysdep.patch (renamed from packages/ltrace/0.5.3/130-add-sysdep.patch)12
-rw-r--r--packages/ltrace/0.5.3/0004-mips.patch (renamed from packages/ltrace/0.5.3/140-mips.patch)26
-rw-r--r--packages/ltrace/0.5.3/0005-mips-remove-CP.patch18
-rw-r--r--packages/ltrace/0.5.3/0006-allow-configurable-arch.patch (renamed from packages/ltrace/0.5.3/150-allow-configurable-arch.patch)24
-rw-r--r--packages/ltrace/0.5.3/0007-fix-missing-ptrace-defines.patch (renamed from packages/ltrace/0.5.3/160-fix-missing-ptrace-defines.patch)26
-rw-r--r--packages/ltrace/0.5.3/0008-lib-supcc.patch (renamed from packages/ltrace/0.5.3/170-lib-supcc.patch)12
-rw-r--r--packages/ltrace/0.5.3/0009-libltrace-genindex.patch15
-rw-r--r--packages/ltrace/0.5.3/0010-ar-configurable.patch (renamed from packages/ltrace/0.5.3/190-ar-configurable.patch)18
-rw-r--r--packages/ltrace/0.5.3/0011-configure-hostos.patch (renamed from packages/ltrace/0.5.3/200-configure-hostos.patch)9
-rw-r--r--packages/ltrace/0.5.3/110-alpha-support.patch11
-rw-r--r--packages/ltrace/0.5.3/140-mips-remove-CP.patch16
-rw-r--r--packages/ltrace/0.5.3/180-libltrace-genindex.patch12
15 files changed, 153 insertions, 124 deletions
diff --git a/packages/ltrace/0.5.3/100-allow-cross-compile.patch b/packages/ltrace/0.5.3/0000-allow-cross-compile.patch
index 58572cd..6515ebd 100644
--- a/packages/ltrace/0.5.3/100-allow-cross-compile.patch
+++ b/packages/ltrace/0.5.3/0000-allow-cross-compile.patch
@@ -2,27 +2,29 @@ This patch is courtesy of OpenEmbedded, by Khem Raj <raj.khem@gmail.com>
http://cgit.openembedded.org/cgit.cgi/openembedded/commit/?id=b85b779688f0abc389e3c25d06b54de8b86385c1
-Index: ltrace-0.5.3/common.h
-===================================================================
---- ltrace-0.5.3.orig/common.h 2009-10-23 23:13:45.700282578 -0700
-+++ ltrace-0.5.3/common.h 2009-10-23 23:14:13.550371553 -0700
+---
+ common.h | 4 ++++
+ configure | 11 ++++-------
+ debug.h | 4 +++-
+ 3 files changed, 11 insertions(+), 8 deletions(-)
+
+--- a/common.h
++++ b/common.h
@@ -1,3 +1,5 @@
+#ifndef COMMON_H
+#define COMMON_H
#include <sys/types.h>
#include <sys/time.h>
#include <stdio.h>
-@@ -251,3 +253,5 @@ extern void * sym2addr(Process *, struct
+@@ -251,3 +253,5 @@
#if 0 /* not yet */
extern int umoven(Process * proc, void * addr, int len, void * laddr);
#endif
+#endif
+
-Index: ltrace-0.5.3/configure
-===================================================================
---- ltrace-0.5.3.orig/configure 2009-10-23 23:13:45.630316494 -0700
-+++ ltrace-0.5.3/configure 2009-10-23 23:13:59.672869527 -0700
-@@ -30,7 +30,7 @@ int main () {
+--- a/configure
++++ b/configure
+@@ -30,7 +30,7 @@
return cplus_demangle();
}
EOF
@@ -31,7 +33,7 @@ Index: ltrace-0.5.3/configure
then
HAVE_LIBIBERTY=1
echo "yes"
-@@ -48,7 +48,7 @@ int main () {
+@@ -48,7 +48,7 @@
return __cxa_demangle();
}
EOF
@@ -40,7 +42,7 @@ Index: ltrace-0.5.3/configure
then
HAVE_LIBSUPC__=1
echo "yes"
-@@ -67,7 +67,7 @@ int main () {
+@@ -67,7 +67,7 @@
return 0;
}
EOF
@@ -49,7 +51,7 @@ Index: ltrace-0.5.3/configure
then
HAVE_ELF_C_READ_MMAP=1
echo "yes"
-@@ -77,15 +77,12 @@ else
+@@ -77,15 +77,12 @@
fi
rm -f conftest.c a.out
@@ -66,17 +68,15 @@ Index: ltrace-0.5.3/configure
sysconfdir='${prefix}/etc'
bindir='${prefix}/bin'
mandir='${prefix}/share/man'
-Index: ltrace-0.5.3/debug.h
-===================================================================
---- ltrace-0.5.3.orig/debug.h 2009-10-23 23:13:45.670276809 -0700
-+++ ltrace-0.5.3/debug.h 2009-10-23 23:14:26.440319785 -0700
+--- a/debug.h
++++ b/debug.h
@@ -1,3 +1,5 @@
+#ifndef DEBUG_H
+#define DEBUG_H
#include <features.h>
/* debug levels:
-@@ -14,4 +16,4 @@ void debug_(int level, const char *file,
+@@ -14,4 +16,4 @@
int xinfdump(long, void *, int);
# define debug(level, expr...) debug_(level, __FILE__, __LINE__, expr)
diff --git a/packages/ltrace/0.5.3/0001-alpha-support.patch b/packages/ltrace/0.5.3/0001-alpha-support.patch
new file mode 100644
index 0000000..8a7710c
--- /dev/null
+++ b/packages/ltrace/0.5.3/0001-alpha-support.patch
@@ -0,0 +1,14 @@
+---
+ sysdeps/linux-gnu/Makefile | 1 +
+ 1 file changed, 1 insertion(+)
+
+--- a/sysdeps/linux-gnu/Makefile
++++ b/sysdeps/linux-gnu/Makefile
+@@ -2,6 +2,7 @@
+ -e s/i.86/i386/ \
+ -e s/sun4u/sparc64/ \
+ -e s/sparc64/sparc/ \
++ -e s/alpha.*/alpha/ \
+ -e s/arm.*/arm/ \
+ -e s/sa110/arm/ \
+ -e s/ppc64/ppc/ \
diff --git a/packages/ltrace/0.5.3/120-debian-ltrace_0.5.3-2.patch b/packages/ltrace/0.5.3/0002-debian-ltrace_0.5.3-2.patch
index 483c743..651230c 100644
--- a/packages/ltrace/0.5.3/120-debian-ltrace_0.5.3-2.patch
+++ b/packages/ltrace/0.5.3/0002-debian-ltrace_0.5.3-2.patch
@@ -1,7 +1,15 @@
Debian patch courtesy of the Debian ltrace maintainer Juan Cespedes <cespedes@debian.org>
---- ltrace-0.5.3.orig/sysdeps/linux-gnu/breakpoint.c
-+++ ltrace-0.5.3/sysdeps/linux-gnu/breakpoint.c
+---
+ sysdeps/linux-gnu/arm/breakpoint.c | 7 +------
+ sysdeps/linux-gnu/breakpoint.c | 5 +++--
+ sysdeps/linux-gnu/ia64/breakpoint.c | 5 +----
+ sysdeps/linux-gnu/ia64/plt.c | 1 +
+ sysdeps/linux-gnu/ia64/regs.c | 1 -
+ 5 files changed, 6 insertions(+), 13 deletions(-)
+
+--- a/sysdeps/linux-gnu/breakpoint.c
++++ b/sysdeps/linux-gnu/breakpoint.c
@@ -6,8 +6,6 @@
#include "common.h"
#include "arch.h"
@@ -21,8 +29,8 @@ Debian patch courtesy of the Debian ltrace maintainer Juan Cespedes <cespedes@de
void
enable_breakpoint(pid_t pid, Breakpoint *sbp) {
unsigned int i, j;
---- ltrace-0.5.3.orig/sysdeps/linux-gnu/arm/breakpoint.c
-+++ ltrace-0.5.3/sysdeps/linux-gnu/arm/breakpoint.c
+--- a/sysdeps/linux-gnu/arm/breakpoint.c
++++ b/sysdeps/linux-gnu/arm/breakpoint.c
@@ -24,10 +24,7 @@
#include <sys/ptrace.h>
@@ -44,16 +52,16 @@ Debian patch courtesy of the Debian ltrace maintainer Juan Cespedes <cespedes@de
debug(1, "arch_disable_breakpoint(%d,%p)", pid, sbp->addr);
---- ltrace-0.5.3.orig/sysdeps/linux-gnu/ia64/plt.c
-+++ ltrace-0.5.3/sysdeps/linux-gnu/ia64/plt.c
+--- a/sysdeps/linux-gnu/ia64/plt.c
++++ b/sysdeps/linux-gnu/ia64/plt.c
@@ -1,4 +1,5 @@
#include <gelf.h>
+#include <sys/ptrace.h>
#include "common.h"
/* A bundle is 128 bits */
---- ltrace-0.5.3.orig/sysdeps/linux-gnu/ia64/breakpoint.c
-+++ ltrace-0.5.3/sysdeps/linux-gnu/ia64/breakpoint.c
+--- a/sysdeps/linux-gnu/ia64/breakpoint.c
++++ b/sysdeps/linux-gnu/ia64/breakpoint.c
@@ -6,10 +6,7 @@
#include <sys/ptrace.h>
@@ -66,8 +74,8 @@ Debian patch courtesy of the Debian ltrace maintainer Juan Cespedes <cespedes@de
static long long
extract_bit_field(char *bundle, int from, int len) {
---- ltrace-0.5.3.orig/sysdeps/linux-gnu/ia64/regs.c
-+++ ltrace-0.5.3/sysdeps/linux-gnu/ia64/regs.c
+--- a/sysdeps/linux-gnu/ia64/regs.c
++++ b/sysdeps/linux-gnu/ia64/regs.c
@@ -7,7 +7,6 @@
#include <asm/rse.h>
diff --git a/packages/ltrace/0.5.3/130-add-sysdep.patch b/packages/ltrace/0.5.3/0003-add-sysdep.patch
index 6fd8d26..8f17f9d 100644
--- a/packages/ltrace/0.5.3/130-add-sysdep.patch
+++ b/packages/ltrace/0.5.3/0003-add-sysdep.patch
@@ -2,11 +2,13 @@ This patch is courtesy of OpenEmbedded, by Khem Raj <raj.khem@gmail.com>
http://cgit.openembedded.org/cgit.cgi/openembedded/commit/?id=b85b779688f0abc389e3c25d06b54de8b86385c1
-Index: ltrace-0.5.3/Makefile.in
-===================================================================
---- ltrace-0.5.3.orig/Makefile.in 2009-10-23 22:06:08.130304691 -0700
-+++ ltrace-0.5.3/Makefile.in 2009-10-23 22:06:53.160369614 -0700
-@@ -39,6 +39,8 @@ ltrace: main.o libltrace.a
+---
+ Makefile.in | 2 ++
+ 1 file changed, 2 insertions(+)
+
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -39,6 +39,8 @@
libltrace.a: sysdeps/sysdep.o $(OBJ)
$(AR) rcv $@ $^
diff --git a/packages/ltrace/0.5.3/140-mips.patch b/packages/ltrace/0.5.3/0004-mips.patch
index b01b7a9..f477fa7 100644
--- a/packages/ltrace/0.5.3/140-mips.patch
+++ b/packages/ltrace/0.5.3/0004-mips.patch
@@ -2,20 +2,22 @@ This patch is courtesy of OpenEmbedded, by Khem Raj <raj.khem@gmail.com>
http://cgit.openembedded.org/cgit.cgi/openembedded/commit/?id=b85b779688f0abc389e3c25d06b54de8b86385c1
-Index: ltrace-0.5.3/sysdeps/linux-gnu/mipsel/plt.c
-===================================================================
---- ltrace-0.5.3.orig/sysdeps/linux-gnu/mipsel/plt.c 2009-10-23 23:25:59.292780574 -0700
-+++ ltrace-0.5.3/sysdeps/linux-gnu/mipsel/plt.c 2009-10-23 23:26:22.671522220 -0700
+---
+ handle_event.c | 3 ++-
+ sysdeps/linux-gnu/mipsel/plt.c | 2 +-
+ sysdeps/linux-gnu/mipsel/regs.c | 1 -
+ 3 files changed, 3 insertions(+), 3 deletions(-)
+
+--- a/sysdeps/linux-gnu/mipsel/plt.c
++++ b/sysdeps/linux-gnu/mipsel/plt.c
@@ -1,4 +1,4 @@
-#include <debug.h>
+#include "debug.h"
#include <gelf.h>
#include <sys/ptrace.h>
#include "common.h"
-Index: ltrace-0.5.3/sysdeps/linux-gnu/mipsel/regs.c
-===================================================================
---- ltrace-0.5.3.orig/sysdeps/linux-gnu/mipsel/regs.c 2009-10-23 23:25:59.312777529 -0700
-+++ ltrace-0.5.3/sysdeps/linux-gnu/mipsel/regs.c 2009-10-23 23:26:08.190311896 -0700
+--- a/sysdeps/linux-gnu/mipsel/regs.c
++++ b/sysdeps/linux-gnu/mipsel/regs.c
@@ -4,7 +4,6 @@
#include <sys/types.h>
#include <sys/ptrace.h>
@@ -24,11 +26,9 @@ Index: ltrace-0.5.3/sysdeps/linux-gnu/mipsel/regs.c
#include "common.h"
#include "mipsel.h"
-Index: ltrace-0.5.3/handle_event.c
-===================================================================
---- ltrace-0.5.3.orig/handle_event.c 2009-10-23 23:29:48.780274445 -0700
-+++ ltrace-0.5.3/handle_event.c 2009-10-23 23:37:32.260284055 -0700
-@@ -573,7 +573,8 @@ handle_breakpoint(Event *event) {
+--- a/handle_event.c
++++ b/handle_event.c
+@@ -573,7 +573,8 @@
void *old_addr;
struct library_symbol *sym= event->proc->callstack[i].c_un.libfunc;
assert(sym);
diff --git a/packages/ltrace/0.5.3/0005-mips-remove-CP.patch b/packages/ltrace/0.5.3/0005-mips-remove-CP.patch
new file mode 100644
index 0000000..5ba3340
--- /dev/null
+++ b/packages/ltrace/0.5.3/0005-mips-remove-CP.patch
@@ -0,0 +1,18 @@
+This patch is courtesy of OpenEmbedded, by Khem Raj <raj.khem@gmail.com>
+
+http://cgit.openembedded.org/cgit.cgi/openembedded/commit/?id=b85b779688f0abc389e3c25d06b54de8b86385c1
+
+---
+ sysdeps/linux-gnu/mipsel/trace.c | 1 -
+ 1 file changed, 1 deletion(-)
+
+--- a/sysdeps/linux-gnu/mipsel/trace.c
++++ b/sysdeps/linux-gnu/mipsel/trace.c
+@@ -127,7 +127,6 @@
+ return ret;
+ } else {
+ // If we need this, I think we can look at [sp+16] for arg_num==4.
+- CP;
+ return 0;
+ }
+ }
diff --git a/packages/ltrace/0.5.3/150-allow-configurable-arch.patch b/packages/ltrace/0.5.3/0006-allow-configurable-arch.patch
index 7208ca8..171d7dd 100644
--- a/packages/ltrace/0.5.3/150-allow-configurable-arch.patch
+++ b/packages/ltrace/0.5.3/0006-allow-configurable-arch.patch
@@ -4,9 +4,14 @@ the arm sysdeps.
Joachim Nilsson <jocke@vmlinux.org>
-diff -ru ltrace-0.5.3.orig/configure ltrace-0.5.3/configure
---- ltrace-0.5.3.orig/configure 2010-01-02 11:05:55.000000000 +0100
-+++ ltrace-0.5.3/configure 2010-01-02 20:49:11.000000000 +0100
+---
+ Makefile.in | 6 ++++--
+ configure | 2 +-
+ sysdeps/linux-gnu/Makefile | 2 +-
+ 3 files changed, 6 insertions(+), 4 deletions(-)
+
+--- a/configure
++++ b/configure
@@ -110,7 +110,7 @@
#
# Makefile.in -> Makefile
@@ -16,10 +21,8 @@ diff -ru ltrace-0.5.3.orig/configure ltrace-0.5.3/configure
for i in $x_subst_vars
do
-Only in ltrace-0.5.3: configure~
-diff -ru ltrace-0.5.3.orig/Makefile.in ltrace-0.5.3/Makefile.in
---- ltrace-0.5.3.orig/Makefile.in 2010-01-02 11:05:55.000000000 +0100
-+++ ltrace-0.5.3/Makefile.in 2010-01-03 01:28:41.000000000 +0100
+--- a/Makefile.in
++++ b/Makefile.in
@@ -1,10 +1,12 @@
#
# ltrace's Makefile.in
@@ -35,14 +38,11 @@ diff -ru ltrace-0.5.3.orig/Makefile.in ltrace-0.5.3/Makefile.in
TOPDIR = $(shell pwd)
prefix = @prefix@
-Only in ltrace-0.5.3: Makefile.in~
-diff -ru ltrace-0.5.3.orig/sysdeps/linux-gnu/Makefile ltrace-0.5.3/sysdeps/linux-gnu/Makefile
---- ltrace-0.5.3.orig/sysdeps/linux-gnu/Makefile 2010-01-02 11:05:55.000000000 +0100
-+++ ltrace-0.5.3/sysdeps/linux-gnu/Makefile 2010-01-02 20:49:51.000000000 +0100
+--- a/sysdeps/linux-gnu/Makefile
++++ b/sysdeps/linux-gnu/Makefile
@@ -1,4 +1,4 @@
-ARCH := $(shell uname -m | sed \
+ARCH ?= $(shell uname -m | sed \
-e s/i.86/i386/ \
-e s/sun4u/sparc64/ \
-e s/sparc64/sparc/ \
-Only in ltrace-0.5.3/sysdeps/linux-gnu: Makefile~
diff --git a/packages/ltrace/0.5.3/160-fix-missing-ptrace-defines.patch b/packages/ltrace/0.5.3/0007-fix-missing-ptrace-defines.patch
index b57a166..f4e31d9 100644
--- a/packages/ltrace/0.5.3/160-fix-missing-ptrace-defines.patch
+++ b/packages/ltrace/0.5.3/0007-fix-missing-ptrace-defines.patch
@@ -5,9 +5,15 @@ The latter of which otherwise fails to build on Arm.
Joachim Nilsson <jocke@vmlinux.org>
-diff -ruN ltrace-0.5.3.orig/sysdeps/linux-gnu/events.c ltrace-0.5.3/sysdeps/linux-gnu/events.c
---- ltrace-0.5.3.orig/sysdeps/linux-gnu/events.c 2009-07-25 17:13:02.000000000 +0200
-+++ ltrace-0.5.3/sysdeps/linux-gnu/events.c 2010-01-03 14:33:46.000000000 +0100
+---
+ sysdeps/linux-gnu/events.c | 3 +--
+ sysdeps/linux-gnu/ppc/plt.c | 1 +
+ sysdeps/linux-gnu/trace.c | 3 +--
+ sysdeps/linux-gnu/trace.h | 32 ++++++++++++++++++++++++++++++++
+ 4 files changed, 35 insertions(+), 4 deletions(-)
+
+--- a/sysdeps/linux-gnu/events.c
++++ b/sysdeps/linux-gnu/events.c
@@ -7,9 +7,8 @@
#include <errno.h>
#include <signal.h>
@@ -19,9 +25,8 @@ diff -ruN ltrace-0.5.3.orig/sysdeps/linux-gnu/events.c ltrace-0.5.3/sysdeps/linu
static Event event;
-diff -ruN ltrace-0.5.3.orig/sysdeps/linux-gnu/trace.c ltrace-0.5.3/sysdeps/linux-gnu/trace.c
---- ltrace-0.5.3.orig/sysdeps/linux-gnu/trace.c 2009-07-25 17:13:02.000000000 +0200
-+++ ltrace-0.5.3/sysdeps/linux-gnu/trace.c 2010-01-03 14:33:38.000000000 +0100
+--- a/sysdeps/linux-gnu/trace.c
++++ b/sysdeps/linux-gnu/trace.c
@@ -5,10 +5,9 @@
#include <unistd.h>
#include <sys/types.h>
@@ -34,9 +39,8 @@ diff -ruN ltrace-0.5.3.orig/sysdeps/linux-gnu/trace.c ltrace-0.5.3/sysdeps/linux
/* If the system headers did not provide the constants, hard-code the normal
values. */
-diff -ruN ltrace-0.5.3.orig/sysdeps/linux-gnu/trace.h ltrace-0.5.3/sysdeps/linux-gnu/trace.h
---- ltrace-0.5.3.orig/sysdeps/linux-gnu/trace.h 1970-01-01 01:00:00.000000000 +0100
-+++ ltrace-0.5.3/sysdeps/linux-gnu/trace.h 2010-01-03 14:33:26.000000000 +0100
+--- /dev/null
++++ b/sysdeps/linux-gnu/trace.h
@@ -0,0 +1,32 @@
+/* If the system headers did not provide the constants, hard-code the normal values. */
+#ifndef __SYSDEPS_TRACE_H__
@@ -70,8 +74,8 @@ diff -ruN ltrace-0.5.3.orig/sysdeps/linux-gnu/trace.h ltrace-0.5.3/sysdeps/linux
+
+#endif /* PTRACE_EVENT_FORK */
+#endif /* __SYSDEPS_TRACE_H__ */
---- ltrace-0.5.3.orig/sysdeps/linux-gnu/ppc/plt.c 2009-07-25 09:13:02.000000000 -0600
-+++ ltrace-0.5.3/sysdeps/linux-gnu/ppc/plt.c 2010-09-28 18:30:07.091618190 -0600
+--- a/sysdeps/linux-gnu/ppc/plt.c
++++ b/sysdeps/linux-gnu/ppc/plt.c
@@ -1,5 +1,6 @@
#include <gelf.h>
#include "common.h"
diff --git a/packages/ltrace/0.5.3/170-lib-supcc.patch b/packages/ltrace/0.5.3/0008-lib-supcc.patch
index 8842b91..cbb1975 100644
--- a/packages/ltrace/0.5.3/170-lib-supcc.patch
+++ b/packages/ltrace/0.5.3/0008-lib-supcc.patch
@@ -1,8 +1,10 @@
-Index: ltrace-0.5.3/configure
-===================================================================
---- ltrace-0.5.3/configure
-+++ ltrace-0.5.3/configure
-@@ -78,7 +78,10 @@ fi
+---
+ configure | 5 ++++-
+ 1 file changed, 4 insertions(+), 1 deletion(-)
+
+--- a/configure
++++ b/configure
+@@ -78,7 +78,10 @@
rm -f conftest.c a.out
CFLAGS='-g -O2'
diff --git a/packages/ltrace/0.5.3/0009-libltrace-genindex.patch b/packages/ltrace/0.5.3/0009-libltrace-genindex.patch
new file mode 100644
index 0000000..929738f
--- /dev/null
+++ b/packages/ltrace/0.5.3/0009-libltrace-genindex.patch
@@ -0,0 +1,15 @@
+---
+ Makefile.in | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -39,7 +39,7 @@
+ $(CC) $(LDFLAGS) $^ $(LIBS) -o $@
+
+ libltrace.a: sysdeps/sysdep.o $(OBJ)
+- $(AR) rcv $@ $^
++ $(AR) rscv $@ $^
+
+ $(OBJ): sysdeps/sysdep.o
+
diff --git a/packages/ltrace/0.5.3/190-ar-configurable.patch b/packages/ltrace/0.5.3/0010-ar-configurable.patch
index 28856a3..99edbce 100644
--- a/packages/ltrace/0.5.3/190-ar-configurable.patch
+++ b/packages/ltrace/0.5.3/0010-ar-configurable.patch
@@ -1,6 +1,10 @@
-diff -ru ltrace-0.5.3.org/Makefile.in ltrace-0.5.3/Makefile.in
---- ltrace-0.5.3.org/Makefile.in 2011-08-21 18:55:15.000000000 +0200
-+++ ltrace-0.5.3/Makefile.in 2011-08-21 18:40:53.000000000 +0200
+---
+ Makefile.in | 1 +
+ configure | 2 +-
+ 2 files changed, 2 insertions(+), 1 deletion(-)
+
+--- a/Makefile.in
++++ b/Makefile.in
@@ -15,6 +15,7 @@
mandir = @mandir@
docdir = $(prefix)/share/doc/ltrace
@@ -9,11 +13,9 @@ diff -ru ltrace-0.5.3.org/Makefile.in ltrace-0.5.3/Makefile.in
CC = @CC@
CFLAGS = -Wall @CFLAGS@
CPPFLAGS = -iquote $(TOPDIR) -iquote $(TOPDIR)/sysdeps/$(OS) -DSYSCONFDIR=\"$(sysconfdir)\" @CPPFLAGS@
-
-diff -ru ltrace-0.5.3.org/configure ltrace-0.5.3/configure
---- ltrace-0.5.3.org/configure 2011-08-21 18:55:15.000000000 +0200
-+++ ltrace-0.5.3/configure 2011-08-21 18:54:46.000000000 +0200
-@@ -113,7 +117,7 @@
+--- a/configure
++++ b/configure
+@@ -113,7 +113,7 @@
#
# Makefile.in -> Makefile
#
diff --git a/packages/ltrace/0.5.3/200-configure-hostos.patch b/packages/ltrace/0.5.3/0011-configure-hostos.patch
index 36563f4..9637212 100644
--- a/packages/ltrace/0.5.3/200-configure-hostos.patch
+++ b/packages/ltrace/0.5.3/0011-configure-hostos.patch
@@ -1,6 +1,9 @@
-diff -ru ltrace-0.5.3.org/configure ltrace-0.5.3/configure
---- ltrace-0.5.3.org/configure 2011-08-21 18:55:15.000000000 +0200
-+++ ltrace-0.5.3/configure 2011-08-21 18:54:46.000000000 +0200
+---
+ configure | 8 ++++++--
+ 1 file changed, 6 insertions(+), 2 deletions(-)
+
+--- a/configure
++++ b/configure
@@ -15,8 +15,12 @@
echo $PACKAGE_VERSION
diff --git a/packages/ltrace/0.5.3/110-alpha-support.patch b/packages/ltrace/0.5.3/110-alpha-support.patch
deleted file mode 100644
index 838b84b..0000000
--- a/packages/ltrace/0.5.3/110-alpha-support.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -ru ltrace-0.5.3.orig/sysdeps/linux-gnu/Makefile ltrace-0.5.3/sysdeps/linux-gnu/Makefile
---- ltrace-0.5.3.orig/sysdeps/linux-gnu/Makefile 2009-07-25 17:13:02.000000000 +0200
-+++ ltrace-0.5.3/sysdeps/linux-gnu/Makefile 2010-01-01 22:20:45.000000000 +0100
-@@ -2,6 +2,7 @@
- -e s/i.86/i386/ \
- -e s/sun4u/sparc64/ \
- -e s/sparc64/sparc/ \
-+ -e s/alpha.*/alpha/ \
- -e s/arm.*/arm/ \
- -e s/sa110/arm/ \
- -e s/ppc64/ppc/ \
diff --git a/packages/ltrace/0.5.3/140-mips-remove-CP.patch b/packages/ltrace/0.5.3/140-mips-remove-CP.patch
deleted file mode 100644
index 4532a8f..0000000
--- a/packages/ltrace/0.5.3/140-mips-remove-CP.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-This patch is courtesy of OpenEmbedded, by Khem Raj <raj.khem@gmail.com>
-
-http://cgit.openembedded.org/cgit.cgi/openembedded/commit/?id=b85b779688f0abc389e3c25d06b54de8b86385c1
-
-Index: ltrace-0.5.3/sysdeps/linux-gnu/mipsel/trace.c
-===================================================================
---- ltrace-0.5.3.orig/sysdeps/linux-gnu/mipsel/trace.c 2009-10-23 23:15:59.822783128 -0700
-+++ ltrace-0.5.3/sysdeps/linux-gnu/mipsel/trace.c 2009-10-23 23:16:10.441268788 -0700
-@@ -127,7 +127,6 @@ gimme_arg(enum tof type, Process *proc,
- return ret;
- } else {
- // If we need this, I think we can look at [sp+16] for arg_num==4.
-- CP;
- return 0;
- }
- }
diff --git a/packages/ltrace/0.5.3/180-libltrace-genindex.patch b/packages/ltrace/0.5.3/180-libltrace-genindex.patch
deleted file mode 100644
index 0b1629b..0000000
--- a/packages/ltrace/0.5.3/180-libltrace-genindex.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -ru ltrace-0.5.3.org/Makefile.in ltrace-0.5.3/Makefile.in
---- ltrace-0.5.3.org/Makefile.in 2011-08-21 18:55:15.000000000 +0200
-+++ ltrace-0.5.3/Makefile.in 2011-08-21 18:40:53.000000000 +0200
-@@ -39,7 +40,7 @@
- $(CC) $(LDFLAGS) $^ $(LIBS) -o $@
-
- libltrace.a: sysdeps/sysdep.o $(OBJ)
-- $(AR) rcv $@ $^
-+ $(AR) rscv $@ $^
-
- $(OBJ): sysdeps/sysdep.o
-