summaryrefslogtreecommitdiff
path: root/packages/strace/4.5.19
diff options
context:
space:
mode:
Diffstat (limited to 'packages/strace/4.5.19')
-rw-r--r--packages/strace/4.5.19/120-fix-disabled-largefile-syscalls.patch22
-rw-r--r--packages/strace/4.5.19/130-statfs64-check.patch53
-rw-r--r--packages/strace/4.5.19/150-undef-syscall.patch42
-rw-r--r--packages/strace/4.5.19/160-fix-check-for-linux-netlink.patch19
-rw-r--r--packages/strace/4.5.19/170-update-configure.patch85
-rw-r--r--packages/strace/4.5.19/version.desc1
6 files changed, 222 insertions, 0 deletions
diff --git a/packages/strace/4.5.19/120-fix-disabled-largefile-syscalls.patch b/packages/strace/4.5.19/120-fix-disabled-largefile-syscalls.patch
new file mode 100644
index 0000000..a555fc2
--- /dev/null
+++ b/packages/strace/4.5.19/120-fix-disabled-largefile-syscalls.patch
@@ -0,0 +1,22 @@
+diff -durN strace-4.5.19.orig/syscall.c strace-4.5.19/syscall.c
+--- strace-4.5.19.orig/syscall.c 2009-10-28 18:47:18.000000000 +0100
++++ strace-4.5.19/syscall.c 2009-10-28 18:47:18.000000000 +0100
+@@ -110,6 +110,18 @@
+ #define TP TRACE_PROCESS
+ #define TS TRACE_SIGNAL
+
++#ifndef HAVE_STATFS64
++/*
++ * Ugly hacks for systems that do not have LFS
++ */
++
++#define sys_truncate64 sys_truncate
++#define sys_ftruncate64 sys_ftruncate
++#define sys_getdents64 sys_getdents
++#define sys_statfs64 sys_statfs
++#define sys_fstatfs64 sys_fstatfs
++#endif
++
+ static const struct sysent sysent0[] = {
+ #include "syscallent.h"
+ };
diff --git a/packages/strace/4.5.19/130-statfs64-check.patch b/packages/strace/4.5.19/130-statfs64-check.patch
new file mode 100644
index 0000000..0959bdd
--- /dev/null
+++ b/packages/strace/4.5.19/130-statfs64-check.patch
@@ -0,0 +1,53 @@
+diff -durN strace-4.5.19.orig/acinclude.m4 strace-4.5.19/acinclude.m4
+--- strace-4.5.19.orig/acinclude.m4 2004-04-14 04:45:53.000000000 +0200
++++ strace-4.5.19/acinclude.m4 2009-10-28 18:47:18.000000000 +0100
+@@ -210,6 +210,26 @@
+ fi
+ ])
+
++dnl ### A macro to determine whether statfs64 is defined.
++AC_DEFUN([AC_STATFS64],
++[AC_MSG_CHECKING(for statfs64 in sys/(statfs|vfs).h)
++AC_CACHE_VAL(ac_cv_type_statfs64,
++[AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#ifdef LINUX
++#include <linux/types.h>
++#include <sys/statfs.h>
++#else
++#include <sys/vfs.h>
++#endif]], [[struct statfs64 st;]])],[ac_cv_type_statfs64=yes],[ac_cv_type_statfs64=no])])
++AC_MSG_RESULT($ac_cv_type_statfs64)
++if test "$ac_cv_type_statfs64" = yes
++then
++ AC_DEFINE([HAVE_STATFS64], 1,
++[Define if statfs64 is available in sys/statfs.h or sys/vfs.h.])
++fi
++])
++
++
++
+ dnl ### A macro to determine if off_t is a long long
+ AC_DEFUN([AC_OFF_T_IS_LONG_LONG],
+ [AC_MSG_CHECKING(for long long off_t)
+diff -durN strace-4.5.19.orig/configure.ac strace-4.5.19/configure.ac
+--- strace-4.5.19.orig/configure.ac 2009-10-12 21:54:43.000000000 +0200
++++ strace-4.5.19/configure.ac 2009-10-28 18:47:18.000000000 +0100
+@@ -187,6 +187,7 @@
+ struct stat.st_level,
+ struct stat.st_rdev])
+ AC_STAT64
++AC_STATFS64
+
+ AC_TYPE_SIGNAL
+ AC_TYPE_UID_T
+diff -durN strace-4.5.19.orig/file.c strace-4.5.19/file.c
+--- strace-4.5.19.orig/file.c 2009-10-21 15:44:04.000000000 +0200
++++ strace-4.5.19/file.c 2009-10-28 18:47:18.000000000 +0100
+@@ -1688,7 +1688,7 @@
+ return 0;
+ }
+
+-#ifdef LINUX
++#ifdef HAVE_STATFS64
+ static void
+ printstatfs64(struct tcb *tcp, long addr)
+ {
diff --git a/packages/strace/4.5.19/150-undef-syscall.patch b/packages/strace/4.5.19/150-undef-syscall.patch
new file mode 100644
index 0000000..7d65e1d
--- /dev/null
+++ b/packages/strace/4.5.19/150-undef-syscall.patch
@@ -0,0 +1,42 @@
+diff -durN strace-4.5.19.orig/linux/syscallent.h strace-4.5.19/linux/syscallent.h
+--- strace-4.5.19.orig/linux/syscallent.h 2009-09-01 21:53:29.000000000 +0200
++++ strace-4.5.19/linux/syscallent.h 2009-10-28 18:47:18.000000000 +0100
+@@ -130,7 +130,11 @@
+ { 2, TF, sys_statfs, "statfs" }, /* 99 */
+ { 2, TD, sys_fstatfs, "fstatfs" }, /* 100 */
+ { 3, 0, sys_ioperm, "ioperm" }, /* 101 */
+- { 2, TD, sys_socketcall, "socketcall", SYS_socketcall }, /* 102 */
++ { 2, TD, sys_socketcall, "socketcall"
++#ifdef __NR_socketcall
++ , SYS_socketcall
++#endif
++ }, /* 102 */
+ { 3, 0, sys_syslog, "syslog" }, /* 103 */
+ { 3, 0, sys_setitimer, "setitimer" }, /* 104 */
+ { 2, 0, sys_getitimer, "getitimer" }, /* 105 */
+@@ -145,7 +149,11 @@
+ { 4, TP, sys_wait4, "wait4", SYS_wait4 }, /* 114 */
+ { 1, 0, sys_swapoff, "swapoff" }, /* 115 */
+ { 1, 0, sys_sysinfo, "sysinfo" }, /* 116 */
+- { 6, 0, sys_ipc, "ipc", SYS_ipc }, /* 117 */
++ { 6, 0, sys_ipc, "ipc"
++#ifdef __NR_ipc
++ , SYS_ipc
++#endif
++ }, /* 117 */
+ { 1, TD, sys_fsync, "fsync" }, /* 118 */
+ { 1, TS, sys_sigreturn, "sigreturn" }, /* 119 */
+ { 5, TP, sys_clone, "clone", SYS_clone }, /* 120 */
+@@ -282,7 +290,11 @@
+ { 3, 0, sys_io_cancel, "io_cancel" }, /* 249 */
+ { 5, 0, sys_fadvise64, "fadvise64" }, /* 250 */
+ { 5, 0, printargs, "SYS_251" }, /* 251 */
+- { 1, TP, sys_exit, "exit_group", __NR_exit_group }, /* 252 */
++ { 1, TP, sys_exit, "exit_group"
++#ifdef __NR_exit_group
++ , __NR_exit_group
++#endif
++ }, /* 252 */
+ { 4, 0, printargs, "lookup_dcookie"}, /* 253 */
+ { 1, 0, sys_epoll_create, "epoll_create" }, /* 254 */
+ { 4, TD, sys_epoll_ctl, "epoll_ctl" }, /* 255 */
diff --git a/packages/strace/4.5.19/160-fix-check-for-linux-netlink.patch b/packages/strace/4.5.19/160-fix-check-for-linux-netlink.patch
new file mode 100644
index 0000000..d8c6b2a
--- /dev/null
+++ b/packages/strace/4.5.19/160-fix-check-for-linux-netlink.patch
@@ -0,0 +1,19 @@
+Dmitry V. Levin [Tue, 3 Nov 2009 16:49:49 +0000]
+
+Fix check for linux/netlink.h on Linux 2.6.32-rc5+
+
+* configure.ac (AC_CHECK_HEADERS): In check for linux/netlink.h, include
+ sys/socket.h instead of linux/socket.h beforehand.
+
+diff --git a/configure.ac b/configure.ac
+--- a/configure.ac
++++ b/configure.ac
+@@ -258,7 +258,7 @@ AC_CHECK_HEADERS([ \
+ ], [], [])
+ AC_CHECK_HEADERS([linux/icmp.h linux/in6.h linux/netlink.h linux/if_packet.h],
+ [], [], [#include <stddef.h>
+-#include <linux/socket.h>])
++#include <sys/socket.h>])
+ AC_CHECK_HEADERS([asm/sigcontext.h], [], [], [#include <signal.h>])
+ AC_CHECK_TYPES([struct sigcontext_struct,
+ struct sigcontext],,, [#include <signal.h>])
diff --git a/packages/strace/4.5.19/170-update-configure.patch b/packages/strace/4.5.19/170-update-configure.patch
new file mode 100644
index 0000000..5d12276
--- /dev/null
+++ b/packages/strace/4.5.19/170-update-configure.patch
@@ -0,0 +1,85 @@
+diff -ruN strace-4.5.19.orig/config.h.in strace-4.5.19/config.h.in
+--- strace-4.5.19.orig/config.h.in 2009-10-21 19:41:12.000000000 +0200
++++ strace-4.5.19/config.h.in 2010-01-01 10:39:36.000000000 +0100
+@@ -161,6 +161,9 @@
+ /* Define if stat64 is available in asm/stat.h. */
+ #undef HAVE_STAT64
+
++/* Define if statfs64 is available in sys/statfs.h or sys/vfs.h. */
++#undef HAVE_STATFS64
++
+ /* Define to 1 if stdbool.h conforms to C99. */
+ #undef HAVE_STDBOOL_H
+
+diff -ruN strace-4.5.19.orig/configure strace-4.5.19/configure
+--- strace-4.5.19.orig/configure 2010-01-01 10:38:49.000000000 +0100
++++ strace-4.5.19/configure 2010-01-01 10:39:36.000000000 +0100
+@@ -5374,6 +5374,44 @@
+
+ fi
+
++{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for statfs64 in sys/(statfs|vfs).h" >&5
++$as_echo_n "checking for statfs64 in sys/(statfs|vfs).h... " >&6; }
++if test "${ac_cv_type_statfs64+set}" = set; then :
++ $as_echo_n "(cached) " >&6
++else
++ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
++/* end confdefs.h. */
++#ifdef LINUX
++#include <linux/types.h>
++#include <sys/statfs.h>
++#else
++#include <sys/vfs.h>
++#endif
++int
++main ()
++{
++struct statfs64 st;
++ ;
++ return 0;
++}
++_ACEOF
++if ac_fn_c_try_compile "$LINENO"; then :
++ ac_cv_type_statfs64=yes
++else
++ ac_cv_type_statfs64=no
++fi
++rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
++fi
++
++{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_type_statfs64" >&5
++$as_echo "$ac_cv_type_statfs64" >&6; }
++if test "$ac_cv_type_statfs64" = yes
++then
++
++$as_echo "#define HAVE_STATFS64 1" >>confdefs.h
++
++fi
++
+
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking return type of signal handlers" >&5
+ $as_echo_n "checking return type of signal handlers... " >&6; }
+@@ -5880,7 +5851,7 @@
+ do :
+ as_ac_Header=`$as_echo "ac_cv_header_$ac_header" | $as_tr_sh`
+ ac_fn_c_check_header_compile "$LINENO" "$ac_header" "$as_ac_Header" "#include <stddef.h>
+-#include <linux/socket.h>
++#include <sys/socket.h>
+ "
+ eval as_val=\$$as_ac_Header
+ if test "x$as_val" = x""yes; then :
+diff -ruN strace-4.5.19.orig/Makefile.in strace-4.5.19/Makefile.in
+--- strace-4.5.19.orig/Makefile.in 2009-10-21 19:41:14.000000000 +0200
++++ strace-4.5.19/Makefile.in 2010-01-01 10:39:36.000000000 +0100
+@@ -42,8 +42,9 @@
+ subdir = .
+ DIST_COMMON = README $(am__configure_deps) $(noinst_HEADERS) \
+ $(srcdir)/Makefile.am $(srcdir)/Makefile.in \
+- $(srcdir)/config.h.in $(top_srcdir)/configure AUTHORS INSTALL \
+- NEWS TODO config.guess config.sub depcomp install-sh missing
++ $(srcdir)/config.h.in $(top_srcdir)/configure AUTHORS \
++ ChangeLog INSTALL NEWS TODO config.guess config.sub depcomp \
++ install-sh missing
+ ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
+ am__aclocal_m4_deps = $(top_srcdir)/acinclude.m4 \
+ $(top_srcdir)/configure.ac
diff --git a/packages/strace/4.5.19/version.desc b/packages/strace/4.5.19/version.desc
new file mode 100644
index 0000000..026d275
--- /dev/null
+++ b/packages/strace/4.5.19/version.desc
@@ -0,0 +1 @@
+obsolete="yes"