config/libc_uClibc.in
author "Yann E. MORIN" <yann.morin.1998@anciens.enib.fr>
Thu Feb 14 22:44:34 2008 +0000 (2008-02-14)
changeset 425 548b7aa23385
parent 61 1207acb66003
permissions -rw-r--r--
Robet P. J. DAY: typoes.
     1 # uClibc options
     2 
     3 choice
     4     bool
     5     prompt "uClibc version"
     6 
     7 config LIBC_V_snapshot
     8     bool
     9     prompt "latest snapshot"
    10 
    11 config LIBC_V_specific_date
    12     bool
    13     prompt "<specific date>"
    14 
    15 config LIBC_V_0_9_28
    16     bool
    17     prompt "0.9.28 (OBSOLETE)"
    18     depends on OBSOLETE
    19 
    20 config LIBC_V_0_9_28_1
    21     bool
    22     prompt "0.9.28.1 (OBSOLETE)"
    23     depends on OBSOLETE
    24 
    25 config LIBC_V_0_9_28_2
    26     bool
    27     prompt "0.9.28.2 (OBSOLETE)"
    28     depends on OBSOLETE
    29 
    30 config LIBC_V_0_9_28_3
    31     bool
    32     prompt "0.9.28.3"
    33 
    34 config LIBC_V_0_9_29
    35     bool
    36     prompt "0.9.29"
    37 
    38 # CT_INSERT_VERSION_ABOVE
    39 # Don't remove above line!
    40 endchoice
    41 
    42 config LIBC_VERSION
    43     string
    44     prompt "Enter date (YYYYMMDD)" if LIBC_V_specific_date
    45     default "snapshot" if LIBC_V_snapshot
    46     default "0.9.28" if LIBC_V_0_9_28
    47     default "0.9.28.1" if LIBC_V_0_9_28_1
    48     default "0.9.28.2" if LIBC_V_0_9_28_2
    49     default "0.9.28.3" if LIBC_V_0_9_28_3
    50     default "0.9.29" if LIBC_V_0_9_29
    51 # CT_INSERT_VERSION_STRING_ABOVE
    52 # Don't remove above line!
    53     help
    54       Enter the date of the snapshot you want to use in the form: YYYYMMDD
    55       where YYYY is the 4-digit year, MM the 2-digit month and DD the 2-digit
    56       day in the month.
    57       
    58       Please note that uClibc site removes snapshots older than a month.
    59 
    60 choice
    61     bool
    62     prompt "Debug level"
    63     default LIBC_UCLIBC_DEBUG_LEVEL_0
    64 
    65 config LIBC_UCLIBC_DEBUG_LEVEL_0
    66     bool
    67     prompt "none"
    68 
    69 config LIBC_UCLIBC_DEBUG_LEVEL_1
    70     bool
    71     prompt "minimal"
    72 
    73 config LIBC_UCLIBC_DEBUG_LEVEL_2
    74     bool
    75     prompt "all"
    76 
    77 endchoice
    78 
    79 config LIBC_UCLIBC_DEBUG_LEVEL
    80     int
    81     default 0 if LIBC_UCLIBC_DEBUG_LEVEL_0
    82     default 1 if LIBC_UCLIBC_DEBUG_LEVEL_1
    83     default 2 if LIBC_UCLIBC_DEBUG_LEVEL_2
    84 
    85 config LIBC_UCLIBC_CONFIG_FILE
    86     string
    87     prompt "Configuration file"
    88     default ""
    89     help
    90       Path to the configuration file.
    91       
    92       You _must_ provide one (for now).
    93 
    94 config LIBC_UCLIBC_LOCALES
    95     bool
    96     prompt "Add support for locales"
    97     default n
    98     help
    99       Say y if you want uClibc to support localisation.
   100 
   101       Note that seems to be broken on recent uClibc releases.