summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlexey Neyman <stilor@att.net>2018-09-29 17:24:18 (GMT)
committerAlexey Neyman <stilor@att.net>2018-09-29 17:24:18 (GMT)
commit2d6ecbda6bb7a891eb29a57a0d92ecbf653eba86 (patch)
tree98ee0732d45c533c0ee12d2fcb53e3d240ebde3f /Makefile.am
parentc3ea42f08ccfcd1768d5b86e6867d45036183a14 (diff)
Move the last bits of release creation into Makefile.am
Fixes #938. Signed-off-by: Alexey Neyman <stilor@att.net>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 5fdee30..92b8af5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -83,3 +83,16 @@ fetch-docs: maintainer/download-docs.sh
.PHONY: gen-tarball-version
gen-tarball-version:
echo $(VERSION) > $(distdir)/.tarball-version
+
+DIGESTS = md5 sha1 sha512
+USE_GPG = yes
+
+dist-create-release: distcheck
+ for a in $(DIST_ARCHIVES); do \
+ for d in $(DIGESTS); do \
+ $${d}sum $${a} > $${a}.$${d}; \
+ done; \
+ if [ "$(USE_GPG)" = "yes" ]; then \
+ gpg --detach-sign $${a}; \
+ fi; \
+ done