summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlexey Neyman <stilor@att.net>2018-11-12 09:15:58 (GMT)
committerAlexey Neyman <stilor@att.net>2018-11-12 09:19:04 (GMT)
commit35bec76b6371057746ac11ac25cffab75b8641db (patch)
treeefaf5f9dce421caff012ccf99af3978bacbb3c0d /Makefile.am
parentfad46ac9d1504a90590cf585a700656e1b58e513 (diff)
Fix installation of the license file
... for ct-ng configured without --enable-local. Also, install licenses in subdirectories of the components. Also, ct-ng configured with --enable-local removed the scripts directory upon `ct-ng distclean`. Also, misspelled CT_WGET/CT_CURL variables prevented use of `ct-ng updatetools`. Fixes #1091. Signed-off-by: Alexey Neyman <stilor@att.net>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 92b8af5..92ee910 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -67,6 +67,8 @@ install-data-hook:
gzip -9 $(DESTDIR)$(man1dir)/$(ctng_progname).1
chmod a+x $(DESTDIR)$(pkgdatadir)/scripts/config.guess
chmod a+x $(DESTDIR)$(pkgdatadir)/scripts/config.sub
+ rm -f $(DESTDIR)$(pkgdatadir)/LICENSE
+ ln -s COPYING $(DESTDIR)$(pkgdatadir)/LICENSE
if INSTALL_BASH_COMPLETION
chmod a-x $(DESTDIR)$(compdir)/$(ctng_progname)
endif