summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlexey Neyman <stilor@att.net>2018-11-28 05:55:42 (GMT)
committerAlexey Neyman <stilor@att.net>2018-11-28 06:38:46 (GMT)
commit3834a7b46918ac5f3a60cc2c602247794f8c9d61 (patch)
tree6b6b9c42514e17755654a07de8c95f1fef7aeb4c /Makefile.am
parentca7edf2fa3283bf6085bfe3711a6423938e55a41 (diff)
Add LICENSE symlink to release tarball.
Fixes #1091. Signed-off-by: Alexey Neyman <stilor@att.net>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 7bc5042..6c224c1 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -78,12 +78,16 @@ endif
uninstall-hook:
rm -f $(DESTDIR)$(man1dir)/$(ctng_progname).1.gz
-dist-hook: fetch-docs gen-tarball-version
+dist-hook: fetch-docs create-symlinks gen-tarball-version
.PHONY: fetch-docs
fetch-docs: maintainer/download-docs.sh
$< $(top_distdir) $(USER_MANUAL_FILES)
+.PHONY: create-symlinks
+create-symlinks:
+ ln -s COPYING $(top_distdir)/LICENSE
+
.PHONY: gen-tarball-version
gen-tarball-version:
echo $(VERSION) > $(distdir)/.tarball-version