summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlexey Neyman <stilor@att.net>2018-03-18 04:43:24 (GMT)
committerAlexey Neyman <stilor@att.net>2018-04-07 19:03:17 (GMT)
commit5159cd7bc070a4fbf013e6c8c259ccb8ef391b0d (patch)
tree99d9914cb726d158649883870c9f929edb7fe880 /Makefile.am
parent5b95b81ea90682c124d5280b64a91a249c464ee4 (diff)
Adjust the paths to match new stuff location
Signed-off-by: Alexey Neyman <stilor@att.net>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 6 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index c58c45f..72df953 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -9,14 +9,16 @@ bin_SCRIPTS = ct-ng
CLEANFILES = $(bin_SCRIPTS)
EXTRA_DIST = ct-ng.in bootstrap
-nobase_dist_pkgdata_DATA = $(verbatim_data)
+# paths.sh generated by configure
+nobase_dist_pkgdata_DATA = $(verbatim_data) paths.sh
do_subst = ( @SED@ \
-e 's,[@]bindir[@],$(bindir),g' \
- -e 's,[@]libdir[@],$(libdir),g' \
-e 's,[@]docdir[@],$(docdir),g' \
-e 's,[@]mandir[@],$(mandir),g' \
+ -e 's,[@]pkgdatadir[@],$(pkgdatadir),g' \
+ -e 's,[@]pkglibexecdir[@],$(pkglibexecdir),g' \
| $(SHELL) config.status --file=- )
-ct-ng: ct-ng.in
- $(AM_V_GEN)$(do_subst) < $< >$@-t && chmod a-w,a+x $@-t && mv $@-t $@
+ct-ng: ct-ng.in Makefile
+ $(AM_V_GEN)$(do_subst) < $< >$@-t && chmod a-w,a+x $@-t && mv -f $@-t $@