summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlexey Neyman <stilor@att.net>2018-03-31 20:12:54 (GMT)
committerAlexey Neyman <stilor@att.net>2018-04-07 19:03:17 (GMT)
commit56d785bd006ab823caf39fc16e2ae6833ef2d780 (patch)
tree3ed15bae8f6157da10e99a09bda4ad65f32ff628 /Makefile.am
parentd6f5c308f9b9564df548d7d6a245a56dbf5360bc (diff)
Docs installation
- Move downloading the pages from a website to a separate script, invoke as dist hook - Install manpage Signed-off-by: Alexey Neyman <stilor@att.net>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 2e98016..e89523c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -9,14 +9,25 @@ bin_SCRIPTS = ct-ng
CLEANFILES = $(bin_SCRIPTS)
EXTRA_DIST = ct-ng.in bootstrap
+man1_MANS = docs/ct-ng.1
+
# paths.sh generated by configure
nobase_dist_pkgdata_DATA = $(verbatim_data) paths.sh
+
+
do_subst = ( @SED@ \
-e 's,[@]docdir[@],$(docdir),g' \
-e 's,[@]pkgdatadir[@],$(pkgdatadir),g' \
-e 's,[@]pkglibexecdir[@],$(pkglibexecdir),g' \
+ -e 's,[@]progname[@],'`echo ct-ng | sed '$(transform)'`',g' \
| $(SHELL) config.status --file=- )
ct-ng: ct-ng.in Makefile
$(AM_V_GEN)$(do_subst) < $< >$@-t && chmod a-w,a+x $@-t && mv -f $@-t $@
+
+docs/ct-ng.1: docs/ct-ng.1.in
+ $(AM_V_GEN)$(MKDIR_P) docs && $(do_subst) < $< >$@-t && mv -f $@-t $@
+
+dist-hook: maintainer/download-docs.sh
+ $< $(top_distdir)