summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlexey Neyman <stilor@att.net>2018-04-09 03:42:07 (GMT)
committerAlexey Neyman <stilor@att.net>2018-04-09 03:42:07 (GMT)
commitc4608f07f7e06a58d48d74b64296be663a94c604 (patch)
tree317cf27c6163d608a3df30e15eecc540c7020ef4 /Makefile.am
parent4e7d0906c1047516ab6517e3abd4a83cba98139d (diff)
Only attempt to chmod bash completion script
... if it has been installed. Signed-off-by: Alexey Neyman <stilor@att.net>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 87e019f..5ee3682 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -66,7 +66,9 @@ install-data-hook:
gzip -9 $(DESTDIR)$(man1dir)/$(ctng_progname).1
chmod +x $(DESTDIR)$(pkgdatadir)/scripts/config.guess
chmod +x $(DESTDIR)$(pkgdatadir)/scripts/config.sub
+if INSTALL_BASH_COMPLETION
chmod -x $(DESTDIR)$(compdir)/$(ctng_progname)
+endif
uninstall-hook:
rm -f $(DESTDIR)$(man1dir)/$(ctng_progname).1.gz