summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlexey Neyman <stilor@att.net>2018-06-07 00:52:17 (GMT)
committerAlexey Neyman <stilor@att.net>2018-06-07 00:52:17 (GMT)
commitd14adeb1d96f784d2f2784ef4a7d03e2d3fe7e1e (patch)
treea7a4da6f4c3d6e0d3ac6ce977ea5e3bf76544f54 /Makefile.am
parent21489af99a997118997e9cdb2356e06832d2c9f0 (diff)
Use git-version-gen to generate version info
Suggested-by: Chris Packham <judge.packham@gmail.com> Signed-off-by: Alexey Neyman <stilor@att.net>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 10 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 5ee3682..84bbe43 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -7,7 +7,8 @@ SUBDIRS = kconfig
bin_SCRIPTS = ct-ng
CLEANFILES = ct-ng bash-completion/ct-ng docs/ct-ng.1
-EXTRA_DIST = bootstrap ct-ng.in bash-completion/ct-ng.in docs/ct-ng.1.in maintainer
+EXTRA_DIST = bootstrap ct-ng.in bash-completion/ct-ng.in \
+ docs/ct-ng.1.in packages maintainer
if INSTALL_BASH_COMPLETION
compdir = @BASH_COMPLETION_DIR@
@@ -73,5 +74,12 @@ endif
uninstall-hook:
rm -f $(DESTDIR)$(man1dir)/$(ctng_progname).1.gz
-dist-hook: maintainer/download-docs.sh
+dist-hook: fetch-docs gen-tarball-version
+
+.PHONY: fetch-docs
+fetch-docs: maintainer/download-docs.sh
$< $(top_distdir) $(USER_MANUAL_FILES)
+
+.PHONY: gen-tarball-version
+gen-tarball-version:
+ echo $(VERSION) > $(distdir)/.tarball-version