summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlexey Neyman <stilor@att.net>2018-02-22 07:34:58 (GMT)
committerAlexey Neyman <stilor@att.net>2018-04-07 19:03:17 (GMT)
commitdbe3877285549d1cdc549826673cdf8f07cf154c (patch)
tree0f0c188389c9dd60da7307be452a5faf59562e35 /Makefile.am
parentd9d4d090265b56dc158b9ffa7a875d0a68f9c57f (diff)
Install ct-ng
Also, move kconfig.mk into the main driver - we'd want kconfig to be a sub-package so there's no sense in writing the installation framework for the ct-ng-specific fragment in an otherwise independent directory. Signed-off-by: Alexey Neyman <stilor@att.net>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 8e25898..37996f8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2,3 +2,17 @@
## vim: set noet :
SUBDIRS = kconfig
+
+bin_SCRIPTS = ct-ng
+CLEANFILES = $(bin_SCRIPTS)
+EXTRA_DIST = ct-ng.in bootstrap
+
+do_subst = ( @SED@ \
+ -e 's,[@]bindir[@],$(bindir),g' \
+ -e 's,[@]libdir[@],$(libdir),g' \
+ -e 's,[@]docdir[@],$(docdir),g' \
+ -e 's,[@]mandir[@],$(mandir),g' \
+ | $(SHELL) config.status --file=- )
+
+ct-ng: ct-ng.in
+ $(AM_V_GEN)$(do_subst) < $< >$@-t && chmod a-w,a+x $@-t && mv $@-t $@