summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlexey Neyman <stilor@att.net>2017-03-09 01:06:46 (GMT)
committerAlexey Neyman <stilor@att.net>2017-03-09 01:06:46 (GMT)
commita61f1c5bc285f4a1a05a25e39ab67a70cac16770 (patch)
tree447a6e61effecaa04f9decd88773e836b5d02991 /configure.ac
parent55c806a360c6dcdc7e53f9b9e777d4c33589157c (diff)
Check for ggrep/gegrep in configure
Signed-off-by: Alexey Neyman <stilor@att.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d80a5cd..d10bf71 100644
--- a/configure.ac
+++ b/configure.ac
@@ -163,6 +163,10 @@ AC_PROG_INSTALL
ACX_WITH_DEPRECATED([grep], [GREP])
AC_ARG_VAR([GREP], [Specify the full path to GNU grep])
+
+# This is not a typo! Prefer GNU grep on macOS if it is installed.
+ACX_PATH_TOOL_REQ([GREP], [ggrep grep], [grep])
+ACX_PATH_TOOL_REQ([EGREP], [gegrep egrep], [egrep])
AC_PROG_GREP
AC_PROG_EGREP
AS_IF([test "$EGREP" != "$GREP -E"],