summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlexey Neyman <stilor@att.net>2019-03-01 01:35:38 (GMT)
committerGitHub <noreply@github.com>2019-03-01 01:35:38 (GMT)
commitc4126d9397353a74ca5aff602dd2c0c527e1dd07 (patch)
treead57c42120f56c2a6e16709553b5960684dd3228 /configure.ac
parentf208f0f782586cd3e2e1c897cf631ad5a8f9ba93 (diff)
parent28e311d2b91d5df019eadcf580d653fc2033fa2e (diff)
Merge pull request #1156 from stilor/more-docker-stuff
More docker stuff
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 12 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 729047d..dddbd27 100644
--- a/configure.ac
+++ b/configure.ac
@@ -122,13 +122,24 @@ CTNG_CHECK_PROGS_REQ([readlink], [readlink])
CTNG_CHECK_PROGS_REQ([tar], [tar])
CTNG_CHECK_PROGS_REQ([gzip], [gzip])
CTNG_CHECK_PROGS_REQ([bzip2], [bzip2])
-CTNG_CHECK_PROGS_REQ([lzip], [lzip])
CTNG_CHECK_PROGS_REQ([xz], [xz])
CTNG_CHECK_PROGS_REQ([unzip], [unzip])
CTNG_CHECK_PROGS_REQ([help2man], [help2man])
CTNG_CHECK_PROGS_REQ([file], [file])
CTNG_CHECK_PROGS_REQ([which], [which])
+# Lzip is optional; all the packages that provide tarballs in .tar.lz format
+# also provide them in some other format. All other formats are currently
+# mandatory as there is at least one package that has no fallback for each
+# of them.
+# FIXME: this configure.ac should be only used for detecting the dependencies
+# of the ct-ng framework itself; anything needed at build time should be
+# determined by crosstool-NG.sh - perhaps, through another 'configure' that
+# runs during `ct-ng build`.
+AC_CHECK_PROGS([lzip], [lzip])
+CTNG_SET_KCONFIG_OPTION([lzip])
+AC_SUBST([lzip])
+
# Not a fatal failure even if we have neither - the tarballs may
# be provided in a local directory.
AC_CHECK_PROGS([wget], [wget])